sync with buildroot2 from uclibc, add two variables PACKAGE_DIR and PATCH, remove...
authorWaldemar Brodkorb <mail@waldemar-brodkorb.de>
Sat, 19 Feb 2005 07:43:13 +0000 (07:43 +0000)
committerWaldemar Brodkorb <mail@waldemar-brodkorb.de>
Sat, 19 Feb 2005 07:43:13 +0000 (07:43 +0000)
SVN-Revision: 265

openwrt/package/Config.in
openwrt/package/Makefile.in

index f7eff0639ef468819a97d74f8e0bd7b5a7603fe2..f22f83e60820fe30d2dd0d4da7e07a60de6b52ab 100644 (file)
@@ -2,15 +2,17 @@
 
 menu "OpenWrt Package Selection"
 
-comment "The default set"
+comment "The absolute minimum"
+source "package/linux/Config.in"
 source "package/busybox/Config.in"
+
+comment "The default set"
 source "package/dnsmasq/Config.in"
-source "package/linux/Config.in"
 source "package/iptables/Config.in"
 source "package/bridge/Config.in"
 
 comment "Suggested Extras"
-source "package/dropbear_sshd/Config.in"
 source "package/ebtables/Config.in"
+source "package/dropbear_sshd/Config.in"
 
 endmenu
index e8ec23efcc2382b936cd8dbf87d3df2f9b083cf0..0d600d0a5abfc54726bf9776e22669ca0377c660 100644 (file)
@@ -1,5 +1,3 @@
-LINKSYS_TGZ_SITE=http://openwrt.openbsd-geek.de
-
 MAKE1=make
 MAKE=make -j$(BR2_JLEVEL)
 
@@ -17,8 +15,8 @@ TARGET_CFLAGS=$(TARGET_OPTIMIZATION) $(TARGET_DEBUGGING)
 HOSTCC:=gcc
 BASE_DIR:=${shell pwd}
 DL_DIR:=$(BASE_DIR)/dl
-#PATCH_DIR=$(BASE_DIR)/sources/patches
 BUILD_DIR:=$(BASE_DIR)/build_$(ARCH)$(ARCH_FPU_SUFFIX)
+PACKAGE_DIR:=$(BASE_DIR)/package
 TARGET_DIR:=$(BUILD_DIR)/root
 TOOL_BUILD_DIR=$(BASE_DIR)/toolchain_build_$(ARCH)$(ARCH_FPU_SUFFIX)
 # Strip off the annoying quoting
@@ -32,6 +30,7 @@ KERNEL_CROSS=$(STAGING_DIR)/bin/$(OPTIMIZE_FOR_CPU)-linux-uclibc-
 TARGET_CROSS=$(STAGING_DIR)/bin/$(OPTIMIZE_FOR_CPU)-linux-uclibc-
 TARGET_CC=$(TARGET_CROSS)gcc
 STRIP=$(TARGET_CROSS)strip --remove-section=.comment --remove-section=.note
+PATCH=toolchain/patch-kernel.sh
 
 
 HOST_ARCH:=$(shell $(HOSTCC) -dumpmachine | sed -e s'/-.*//' \