build: fix ldconfig executable error in python
authorDamien Mascord <tusker@tusker.org>
Mon, 1 Nov 2021 09:06:20 +0000 (20:06 +1100)
committerBaptiste Jonglez <git@bitsofnetworks.org>
Tue, 2 Nov 2021 17:18:00 +0000 (18:18 +0100)
The empty executable is causing problems with meson builds, due to the
error: OSError: [Errno 8] Exec format error: 'ldconfig'

This patch changes the empty ldconfig stub to symlink to /bin/true to
work around this issue.

Fixes: FS#4117
Fixes: 3bd31cc4d2ff ("tools/meson: update to 0.60.0")
Signed-off-by: Damien Mascord <tusker@tusker.org>
Tested-by: Aleksander Jan Bajkowski <olek2@wp.pl> # Tested on Debian 11
Tested-By: Lucian Cristian <lucian.cristian@gmail.com>
Tested-By: Baptiste Jonglez <git@bitsofnetworks.org>
Cc: Rosen Penev <rosenp@gmail.com>
include/prereq-build.mk

index ce6873cf524d7affba9d5dc38d22c97da154e1df..e1918f002787be0abae4953cfedc0cc327122ff7 100644 (file)
@@ -198,5 +198,4 @@ prereq: $(STAGING_DIR_HOST)/bin/mkhash
 
 # Install ldconfig stub
 $(eval $(call TestHostCommand,ldconfig-stub,Failed to install stub, \
-       touch $(STAGING_DIR_HOST)/bin/ldconfig && \
-       chmod +x $(STAGING_DIR_HOST)/bin/ldconfig))
+       $(LN) /bin/true $(STAGING_DIR_HOST)/bin/ldconfig))