kernel: bump 4.14 to 4.14.87
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Tue, 11 Dec 2018 12:31:35 +0000 (13:31 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Thu, 13 Dec 2018 12:29:03 +0000 (13:29 +0100)
Refreshed all patches.

Compile-tested on: cns3xxx, imx6
Runtime-tested on: cns3xxx, imx6

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/generic/hack-4.14/207-disable-modorder.patch
target/linux/generic/hack-4.14/902-debloat_proc.patch

index 953c513fb868165243734bf57e38fa419202d578..6f93ebf23f326b159c88ce2ce8814a101d97bf8a 100644 (file)
@@ -3,10 +3,10 @@
 LINUX_RELEASE?=1
 
 LINUX_VERSION-4.9 = .144
-LINUX_VERSION-4.14 = .86
+LINUX_VERSION-4.14 = .87
 
 LINUX_KERNEL_HASH-4.9.144 = 05d17f434d22e9fa2f9084cdf6858383564883d23a1d11ce4dae4b217662782b
-LINUX_KERNEL_HASH-4.14.86 = da9260a9022b917733201b89b5314847cb3332c31e70acb5e9b547956c266e28
+LINUX_KERNEL_HASH-4.14.87 = 36744d7d657dab23e455a8096e4ad2dc6a25f25fdce062d8a8bdf4499112e125
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index fe6d5212f26d6f8ac7158db0f1f97df5634a9132..0619dcaa7bfc627226232d831b91c5488299cdea 100644 (file)
@@ -15,7 +15,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/Makefile
 +++ b/Makefile
-@@ -1234,7 +1234,6 @@ all: modules
+@@ -1237,7 +1237,6 @@ all: modules
  
  PHONY += modules
  modules: $(vmlinux-dirs) $(if $(KBUILD_BUILTIN),vmlinux) modules.builtin
@@ -23,7 +23,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        @$(kecho) '  Building modules, stage 2.';
        $(Q)$(MAKE) -f $(srctree)/scripts/Makefile.modpost
  
-@@ -1263,7 +1262,6 @@ _modinst_:
+@@ -1266,7 +1265,6 @@ _modinst_:
                rm -f $(MODLIB)/build ; \
                ln -s $(CURDIR) $(MODLIB)/build ; \
        fi
index 4e700ca0b72c138754c8ced83572b601147856e3..cae6d66e7df4c64eceeb04122f5cd9b8b0abc74f 100644 (file)
@@ -243,7 +243,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  }
 --- a/mm/vmstat.c
 +++ b/mm/vmstat.c
-@@ -1951,10 +1951,12 @@ void __init init_mm_internals(void)
+@@ -1955,10 +1955,12 @@ void __init init_mm_internals(void)
        start_shepherd_timer();
  #endif
  #ifdef CONFIG_PROC_FS