patch to allow iproute2 to be cross compiled. could be a sed hack if we wanted/needed.
authorNed Ludd <solar@gentoo.org>
Fri, 4 Jun 2004 02:00:59 +0000 (02:00 +0000)
committerNed Ludd <solar@gentoo.org>
Fri, 4 Jun 2004 02:00:59 +0000 (02:00 +0000)
SVN-Revision: 57

obsolete-buildroot/sources/iproute2-cross-ar-20010824.patch [new file with mode: 0644]

diff --git a/obsolete-buildroot/sources/iproute2-cross-ar-20010824.patch b/obsolete-buildroot/sources/iproute2-cross-ar-20010824.patch
new file mode 100644 (file)
index 0000000..62ed488
--- /dev/null
@@ -0,0 +1,28 @@
+diff -Nrup iproute2.orig/lib/Makefile iproute2/lib/Makefile
+--- iproute2.orig/lib/Makefile 2000-04-16 13:42:52.000000000 -0400
++++ iproute2/lib/Makefile      2004-06-03 19:17:51.000000000 -0400
+@@ -6,10 +6,10 @@ NLOBJ=ll_map.o libnetlink.o
+ all: libnetlink.a libutil.a
+ libnetlink.a: $(NLOBJ)
+-      ar rcs $@ $(NLOBJ)
++      $(AR) rcs $@ $(NLOBJ)
+ libutil.a: $(UTILOBJ) $(ADDLIB)
+-      ar rcs $@ $(UTILOBJ) $(ADDLIB)
++      $(AR) rcs $@ $(UTILOBJ) $(ADDLIB)
+ clean:
+       rm -f $(NLOBJ) $(UTILOBJ) $(ADDLIB) libnetlink.a libutil.a
+diff -Nrup iproute2.orig/tc/Makefile iproute2/tc/Makefile
+--- iproute2.orig/tc/Makefile  2000-04-16 13:42:53.000000000 -0400
++++ iproute2/tc/Makefile       2004-06-03 19:18:08.000000000 -0400
+@@ -43,7 +43,7 @@ all: libtc.a tc
+ tc: $(TCOBJ) $(LIBNETLINK) $(LIBUTIL) $(TCLIB)
+ libtc.a: $(TCLIB)
+-      ar rcs $@ $(TCLIB)
++      $(AR) rcs $@ $(TCLIB)
+ clean:
+       rm -f $(TCOBJ) $(TCLIB) libtc.a tc