arm-trusted-firmware-mvebu: install to own subdir
authorAndre Heider <a.heider@gmail.com>
Thu, 20 Aug 2020 05:53:41 +0000 (07:53 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Fri, 18 Sep 2020 19:42:06 +0000 (21:42 +0200)
Lift the dependency on the build order, where flash-image.bin may be missing
from the u-boot dir.

While at it, also install the uart images for rescue purposes.

Signed-off-by: Andre Heider <a.heider@gmail.com>
package/boot/arm-trusted-firmware-mvebu/Makefile

index 7f829f94c6de7f81dc10ce294dd25ad2d14d7172..068fe507e9d437caec0d734a9060f9816a1c9f78 100644 (file)
@@ -107,7 +107,9 @@ MAKE_FLAGS = \
        fip
 
 define Build/InstallDev
-       $(CP) $(PKG_BUILD_DIR)/build/$(PLAT)/release/flash-image.bin $(BIN_DIR)/u-boot-$(BOARDNAME)/
+       $(INSTALL_DIR) $(BIN_DIR)/flash-image-$(BOARDNAME)
+       $(CP) $(PKG_BUILD_DIR)/build/$(PLAT)/release/flash-image.bin $(BIN_DIR)/flash-image-$(BOARDNAME)/
+       $(CP) $(PKG_BUILD_DIR)/build/$(PLAT)/release/uart-images.tgz $(BIN_DIR)/flash-image-$(BOARDNAME)/
 endef
 
 $(eval $(call BuildPackage,arm-trusted-firmware-mvebu/uDPU))