If the *.img file is larger than 0x1e8000 loading it with flash -s 0x100000 -d 0xffe0...
authorFlorian Fainelli <florian@openwrt.org>
Sat, 5 Jul 2008 13:38:19 +0000 (13:38 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 5 Jul 2008 13:38:19 +0000 (13:38 +0000)
on the bootloader prompt will destroy the bootloader and brick the device. The attached patch tries to implement a size check and renames the image into *.img.too_big. It applies to svn r11401.
Signed-off-by: Joerg Albert <jal2@gmx.de>
SVN-Revision: 11662

target/linux/rdc/image/Makefile

index a8ad0996683253eb12eaeeed00c5f8cc9b636868..f1fed220e76b5df7b532df0b72569323ec5d1102 100644 (file)
@@ -47,6 +47,7 @@ define Image/Build/wl153
        echo -ne "\x$$$$(cut -c 7,8 < $(KDIR)/rdSize)\x$$$$(cut -c 5,6 < $(KDIR)/rdSize)\x$$$$(cut -c 3,4 < $(KDIR)/rdSize)\x$$$$(cut -c 1,2 < $(KDIR)/rdSize)WRRM" >> $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).img
        cat $(KDIR)/bzSize.tmp $(KDIR)/bzImage $(KDIR)/root.$(1).gz >> $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).img
        $(RM) $(KDIR)/bzSize.tmp $(KDIR)/bzSize $(KDIR)/rdSize
+       if [ `ls -l $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).img | sed -r 's/^[^[:blank:]]+[[:blank:]]+[^[:blank:]]+[[:blank:]]+[^[:blank:]]+[[:blank:]]+[^[:blank:]]+[[:blank:]]+([^[:blank:]]+).+$$$$/\1/'` -gt $$$$((0xffff0000-0xffe08000)) ]; then mv $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).img $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).img.too_big; echo "#ERR image too big"; fi 
 endef
 
 define Image/Build/dir450