ramips: increase HiWiFi HC5962 kernel partition to 4M
authorDENG Qingfang <dengqf6@mail2.sysu.edu.cn>
Mon, 6 Apr 2020 05:17:43 +0000 (13:17 +0800)
committerChuanhong Guo <gch981213@gmail.com>
Sat, 18 Apr 2020 03:50:57 +0000 (11:50 +0800)
Increase kernel partition because 2M is insufficient for 5.4
Because the partition changes, previous version of OpenWrt cannot upgrade
to this version, and requires a new installation

Recovery to stock instruction:
1. Download stock firmware at
   http://ur.ikcd.net/HC5962-sysupgrade-20171221-b00a04d1.bin
2. Power off the router
3. Press and hold the reset button for 4~6 sec while power it back on
4. Connect a PC to router's LAN
5. Visit http://192.168.2.1 and upload the firmware

Then repeat the instruction in edae3479e64e to install OpenWrt

Signed-off-by: DENG Qingfang <dengqf6@mail2.sysu.edu.cn>
target/linux/ramips/dts/mt7621_hiwifi_hc5962.dts
target/linux/ramips/image/mt7621.mk

index 9d60d509abb53ff26efa8b67fa08e0770cf227de..ec76b3584050d1c4eac58d9bb33466a2c21bf530 100644 (file)
 
                partition@140000 {
                        label = "kernel";
-                       reg = <0x140000 0x200000>;
+                       reg = <0x140000 0x400000>;
                };
 
-               partition@340000 {
+               partition@540000 {
                        label = "ubi";
-                       reg = <0x340000 0x1E00000>;
+                       reg = <0x540000 0x1c00000>;
                };
 
                partition@2140000 {
index 6e64fb8bf1810197fd243424e0f9ca6c5abed125..a72f758c96894d14cdb539e31dce746d6336438a 100644 (file)
@@ -339,7 +339,7 @@ TARGET_DEVICES += gnubee_gb-pc2
 define Device/hiwifi_hc5962
   BLOCKSIZE := 128k
   PAGESIZE := 2048
-  KERNEL_SIZE := 2097152
+  KERNEL_SIZE := 4096k
   UBINIZE_OPTS := -E 5
   IMAGE_SIZE := 32768k
   IMAGES += factory.bin
@@ -349,9 +349,6 @@ define Device/hiwifi_hc5962
   DEVICE_VENDOR := HiWiFi
   DEVICE_MODEL := HC5962
   DEVICE_PACKAGES := kmod-mt7603 kmod-mt76x2 kmod-usb3 wpad-basic
-  SUPPORTED_DEVICES += hc5962
-  # Kernel partition too small
-  DEFAULT := n
 endef
 TARGET_DEVICES += hiwifi_hc5962