tools/lz4: remove patches
authorRosen Penev <rosenp@gmail.com>
Wed, 22 May 2024 21:14:23 +0000 (14:14 -0700)
committerChristian Marangi <ansuelsmth@gmail.com>
Thu, 23 May 2024 09:49:02 +0000 (11:49 +0200)
meson is used to build it since 291b137. No need to patch Makefiles.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
Link: https://github.com/openwrt/openwrt/pull/15524
Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
tools/lz4/patches/001-add-make-ENABLE_DOCS-configurable.patch [deleted file]
tools/lz4/patches/002-makefile-install-links-from-same-dir.patch [deleted file]

diff --git a/tools/lz4/patches/001-add-make-ENABLE_DOCS-configurable.patch b/tools/lz4/patches/001-add-make-ENABLE_DOCS-configurable.patch
deleted file mode 100644 (file)
index 5d6dca3..0000000
+++ /dev/null
@@ -1,60 +0,0 @@
-+++ a/programs/Makefile        2022-08-15 15:45:31.000000000 -0700
---- b/programs/Makefile        2022-11-28 16:34:21.315593784 -0800
-@@ -66,6 +66,7 @@
- MD2ROFF   = ronn
- MD2ROFF_FLAGS = --roff --warnings --manual="User Commands" --organization="lz4 $(LZ4_VERSION)"
-+ENABLE_DOCS ?= 1
- default: lz4-release
-@@ -120,6 +121,7 @@
- lz4c32 : $(SRCFILES)
-       $(CC) $(FLAGS) $^ -o $@$(EXT)
-+ifeq ($(ENABLE_DOCS),1)
- lz4.1: lz4.1.md $(LIBVER_SRC)
-       cat $< | $(MD2ROFF) $(MD2ROFF_FLAGS) | $(SED) -n '/^\.\\\".*/!p' > $@
-@@ -130,6 +132,7 @@
- preview-man: clean-man man
-       man ./lz4.1
-+endif
- clean:
- ifeq ($(WINBASED),yes)
-@@ -172,16 +175,19 @@
- install: lz4
-       @echo Installing binaries in $(DESTDIR)$(bindir)
--      $(INSTALL_DIR) $(DESTDIR)$(bindir)/ $(DESTDIR)$(man1dir)/
-+      $(INSTALL_DIR) $(DESTDIR)$(bindir)/
-       $(INSTALL_PROGRAM) lz4$(EXT) $(DESTDIR)$(bindir)/lz4$(EXT)
-       $(LN_SF) lz4$(EXT) $(DESTDIR)$(bindir)/lz4c$(EXT)
-       $(LN_SF) lz4$(EXT) $(DESTDIR)$(bindir)/lz4cat$(EXT)
-       $(LN_SF) lz4$(EXT) $(DESTDIR)$(bindir)/unlz4$(EXT)
-+ifeq ($(ENABLE_DOCS),1)
-       @echo Installing man pages in $(DESTDIR)$(man1dir)
-+      $(INSTALL_DIR) $(DESTDIR)$(man1dir)/
-       $(INSTALL_DATA) lz4.1 $(DESTDIR)$(man1dir)/lz4.1
-       $(LN_SF) lz4.1 $(DESTDIR)$(man1dir)/lz4c.1
-       $(LN_SF) lz4.1 $(DESTDIR)$(man1dir)/lz4cat.1
-       $(LN_SF) lz4.1 $(DESTDIR)$(man1dir)/unlz4.1
-+endif
-       @echo lz4 installation completed
- uninstall:
-@@ -189,10 +195,12 @@
-       $(RM) $(DESTDIR)$(bindir)/unlz4$(EXT)
-       $(RM) $(DESTDIR)$(bindir)/lz4$(EXT)
-       $(RM) $(DESTDIR)$(bindir)/lz4c$(EXT)
-+ifeq ($(ENABLE_DOCS),1)
-       $(RM) $(DESTDIR)$(man1dir)/lz4.1
-       $(RM) $(DESTDIR)$(man1dir)/lz4c.1
-       $(RM) $(DESTDIR)$(man1dir)/lz4cat.1
-       $(RM) $(DESTDIR)$(man1dir)/unlz4.1
-+endif
-       @echo lz4 programs successfully uninstalled
- endif
diff --git a/tools/lz4/patches/002-makefile-install-links-from-same-dir.patch b/tools/lz4/patches/002-makefile-install-links-from-same-dir.patch
deleted file mode 100644 (file)
index 159dc67..0000000
+++ /dev/null
@@ -1,71 +0,0 @@
-diff -ur a/lib/Makefile b/lib/Makefile
---- a/lib/Makefile     2022-12-04 23:49:06.336839263 -0800
-+++ b/lib/Makefile     2022-12-05 00:00:59.172307488 -0800
-@@ -195,8 +195,8 @@
-       $(INSTALL_PROGRAM) dll/$(LIBLZ4_EXP) $(DESTDIR)$(libdir)
-     else
-       $(INSTALL_PROGRAM) liblz4.$(SHARED_EXT_VER) $(DESTDIR)$(libdir)
--      $(LN_SF) liblz4.$(SHARED_EXT_VER) $(DESTDIR)$(libdir)/liblz4.$(SHARED_EXT_MAJOR)
--      $(LN_SF) liblz4.$(SHARED_EXT_VER) $(DESTDIR)$(libdir)/liblz4.$(SHARED_EXT)
-+      (cd $(DESTDIR)$(libdir) && $(LN_SF) liblz4.$(SHARED_EXT_VER) liblz4.$(SHARED_EXT_MAJOR))
-+      (cd $(DESTDIR)$(libdir) && $(LN_SF) liblz4.$(SHARED_EXT_MAJOR) liblz4.$(SHARED_EXT))
-     endif
-   endif
-       @echo Installing headers in $(DESTDIR)$(includedir)
-diff -ur a/Makefile b/Makefile
---- a/Makefile 2022-12-04 23:49:06.336839263 -0800
-+++ b/Makefile 2022-12-04 23:42:09.693836654 -0800
-@@ -77,12 +77,12 @@
- .PHONY: clean
- clean:
--      $(MAKE) -C $(LZ4DIR) $@ > $(VOID)
--      $(MAKE) -C $(PRGDIR) $@ > $(VOID)
--      $(MAKE) -C $(TESTDIR) $@ > $(VOID)
--      $(MAKE) -C $(EXDIR) $@ > $(VOID)
--      $(MAKE) -C $(FUZZDIR) $@ > $(VOID)
--      $(MAKE) -C contrib/gen_manual $@ > $(VOID)
-+      $(MAKE) -C $(LZ4DIR) $@
-+      $(MAKE) -C $(PRGDIR) $@
-+      $(MAKE) -C $(TESTDIR) $@
-+      $(MAKE) -C $(EXDIR) $@
-+      $(MAKE) -C $(FUZZDIR) $@
-+      $(MAKE) -C contrib/gen_manual $@
-       $(RM) lz4$(EXT)
-       $(RM) -r $(CMAKE_BUILD_DIR)
-       @echo Cleaning completed
-diff -ur a/programs/Makefile b/programs/Makefile
---- a/programs/Makefile        2022-12-04 23:49:06.336839263 -0800
-+++ b/programs/Makefile        2022-12-04 23:42:30.849582910 -0800
-@@ -138,7 +138,7 @@
- ifeq ($(WINBASED),yes)
-       $(RM) *.rc
- endif
--      $(MAKE) -C $(LZ4DIR) $@ > $(VOID)
-+      $(MAKE) -C $(LZ4DIR) $@
-       $(RM) core *.o *.test tmp* \
-            lz4$(EXT) lz4c$(EXT) lz4c32$(EXT) lz4-wlib$(EXT) \
-            unlz4$(EXT) lz4cat$(EXT)
-@@ -177,16 +177,16 @@
-       @echo Installing binaries in $(DESTDIR)$(bindir)
-       $(INSTALL_DIR) $(DESTDIR)$(bindir)/
-       $(INSTALL_PROGRAM) lz4$(EXT) $(DESTDIR)$(bindir)/lz4$(EXT)
--      $(LN_SF) lz4$(EXT) $(DESTDIR)$(bindir)/lz4c$(EXT)
--      $(LN_SF) lz4$(EXT) $(DESTDIR)$(bindir)/lz4cat$(EXT)
--      $(LN_SF) lz4$(EXT) $(DESTDIR)$(bindir)/unlz4$(EXT)
-+      (cd $(DESTDIR)$(bindir) && $(LN_SF) lz4$(EXT) lz4c$(EXT))
-+      (cd $(DESTDIR)$(bindir) && $(LN_SF) lz4$(EXT) lz4cat$(EXT))
-+      (cd $(DESTDIR)$(bindir) && $(LN_SF) lz4$(EXT) unlz4$(EXT))
- ifeq ($(ENABLE_DOCS),1)
-       @echo Installing man pages in $(DESTDIR)$(man1dir)
-       $(INSTALL_DIR) $(DESTDIR)$(man1dir)/
-       $(INSTALL_DATA) lz4.1 $(DESTDIR)$(man1dir)/lz4.1
--      $(LN_SF) lz4.1 $(DESTDIR)$(man1dir)/lz4c.1
--      $(LN_SF) lz4.1 $(DESTDIR)$(man1dir)/lz4cat.1
--      $(LN_SF) lz4.1 $(DESTDIR)$(man1dir)/unlz4.1
-+      (cd $(DESTDIR)$(man1dir) && $(LN_SF) lz4.1 lz4c.1)
-+      (cd $(DESTDIR)$(man1dir) && $(LN_SF) lz4.1 lz4cat.1)
-+      (cd $(DESTDIR)$(man1dir) && $(LN_SF) lz4.1 unlz4.1)
- endif
-       @echo lz4 installation completed