mvebu: Replace the padjffs2 call by the generic definition
authorImre Kaloz <kaloz@openwrt.org>
Wed, 14 Jan 2015 11:37:29 +0000 (11:37 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Wed, 14 Jan 2015 11:37:29 +0000 (11:37 +0000)
The mvebu image Makefile directly calls the padjffs2 utility, while there's an
generic make function to do just that. Switch to it

Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com>
SVN-Revision: 43968

target/linux/mvebu/image/Makefile

index 92571e215342122f51587ea599433ca5df1527f1..f265dc43d25d0163679533ec8b3b71ce7414eda6 100644 (file)
@@ -44,7 +44,7 @@ define Image/BuildKernel
 endef
 
 define Image/Build/squashfs
-       $(STAGING_DIR_HOST)/bin/padjffs2 $(KDIR)/root.squashfs 128
+       $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
        $(foreach nandboard,$(NANDBOARDS),$(call Image/Build/UbinizeImage,$(nandboard),,squashfs,$(UBI_OPTS));)
        ( \
                dd if=$(KDIR)/uImage-armada-xp-mamba bs=3072k conv=sync; \