kernel: kmod-rtc-pcf2127: Fix dependencies
authorHauke Mehrtens <hauke@hauke-m.de>
Sat, 12 Oct 2019 20:31:38 +0000 (22:31 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 12 Oct 2019 20:36:23 +0000 (22:36 +0200)
Add missing dependencies to i2c-core and regmap-spi. These get activated
when these modules are build in this driver, which is the case when we
build all modules. This fixes the build on some targets. This was found
by the buildbot.

Fixes: 34e2526f9fcc ("kernel: add kmod-rtc-pcf2127")
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/kernel/linux/modules/other.mk

index 3abd1f48f6169366f6e059f19ce9107f8e7a38f0..276a8f09acd68cc45535df00885a75c9a4a241db 100644 (file)
@@ -603,6 +603,7 @@ define KernelPackage/rtc-pcf2127
   SUBMENU:=$(OTHER_MENU)
   TITLE:=NXP PCF2127 and PCF2129 RTC support
   DEFAULT:=m if ALL_KMODS && RTC_SUPPORT
+  DEPENDS:=+kmod-i2c-core +kmod-regmap-spi
   KCONFIG:=CONFIG_RTC_DRV_PCF2127 \
        CONFIG_RTC_CLASS=y
   FILES:=$(LINUX_DIR)/drivers/rtc/rtc-pcf2127.ko