iproute2: q_cake: Add printing of no-split-gso option
authorKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Wed, 12 Sep 2018 07:24:37 +0000 (08:24 +0100)
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Wed, 12 Sep 2018 09:33:53 +0000 (10:33 +0100)
When the GSO splitting was turned into dual split-gso/no-split-gso options,
the printing of the latter was left out. Add that, so output is consistent
with the options passed

Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
(cherry picked from commit 8cac8572897c28e902218b445aa9bed82c40989f)

package/network/utils/iproute2/Makefile
package/network/utils/iproute2/patches/950-add-cake-to-tc.patch

index 66192c7bac08d7a65bf1dbdfecf3311b4c6c3993..91092b2f51793829315f402bd62e9857d225eef7 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iproute2
 PKG_VERSION:=4.16.0
-PKG_RELEASE:=6
+PKG_RELEASE:=7
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@KERNEL/linux/utils/net/iproute2
index ea1f3c5516ee919f26fc8adfaf48cbed5e2cadb9..038ca2333768005ccf499f84e7aca77283749d7c 100644 (file)
  TCMODULES += e_bpf.o
 --- /dev/null
 +++ b/tc/q_cake.c
-@@ -0,0 +1,799 @@
+@@ -0,0 +1,801 @@
 +// SPDX-License-Identifier: GPL-2.0 OR BSD-3-Clause
 +
 +/*
 +
 +      if (split_gso)
 +              print_string(PRINT_FP, NULL, "split-gso ", NULL);
++      else
++              print_string(PRINT_FP, NULL, "no-split-gso ", NULL);
 +      print_bool(PRINT_JSON, "split_gso", NULL, split_gso);
 +
 +      if (interval)