kernel: bump 4.9 to 4.9.210
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 20 Jan 2020 10:02:40 +0000 (11:02 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 20 Jan 2020 12:44:38 +0000 (13:44 +0100)
Refreshed all patches.

Compile-tested on: ar71xx
Runtime-tested on: ar71xx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/ar71xx/patches-4.9/910-unaligned_access_hacks.patch
target/linux/generic/hack-4.9/911-kobject_add_broadcast_uevent.patch
target/linux/ixp4xx/patches-4.9/160-delayed_uart_io.patch

index e6f4635dd6fb1a71f1ef631ee776b3779277b7f5..35188a0776462b52fd101b3e9b561d3579b48531 100644 (file)
@@ -2,10 +2,10 @@
 
 LINUX_RELEASE?=1
 
-LINUX_VERSION-4.9 = .209
+LINUX_VERSION-4.9 = .210
 LINUX_VERSION-4.14 = .164
 
-LINUX_KERNEL_HASH-4.9.209 = 0258d5bef915fddcdd584a26ae91bafa996d7e400e725d36329ee44041aa59e1
+LINUX_KERNEL_HASH-4.9.210 = a0915203836d02cc3cd70252904700412c4a409737a81b392465fb70d7625313
 LINUX_KERNEL_HASH-4.14.164 = a2031061f3f1472b7fa929f7d0274dd985c8d03ca847acfec1c47847fb7deb4b
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index 3e367589f91b6e4ae5ed40156267ac05abd204bb..6fee84b266c475f9872ee30f60233f044f5f580c 100644 (file)
  
 --- a/net/ipv4/tcp_input.c
 +++ b/net/ipv4/tcp_input.c
-@@ -3929,14 +3929,16 @@ static bool tcp_parse_aligned_timestamp(
+@@ -3933,14 +3933,16 @@ static bool tcp_parse_aligned_timestamp(
  {
        const __be32 *ptr = (const __be32 *)(th + 1);
  
index d827ace9e00842ccd3f77881448f36f72f3ffef3..7b853aa582c58f17b3955120db0c26bd4c886c83 100644 (file)
@@ -20,7 +20,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  #ifdef CONFIG_UEVENT_HELPER
  /* path to the userspace helper executed on an event */
  extern char uevent_helper[];
-@@ -239,4 +241,7 @@ int add_uevent_var(struct kobj_uevent_en
+@@ -241,4 +243,7 @@ int add_uevent_var(struct kobj_uevent_en
  int kobject_action_type(const char *buf, size_t count,
                        enum kobject_action *type);
  
index 95cc5680cd902d167b50a4439cd6467a2a217e0d..a520cb36825868c845889bd86544c625d9175a8f 100644 (file)
@@ -26,7 +26,7 @@
        case UPIO_MEM:
        case UPIO_MEM16:
        case UPIO_MEM32:
-@@ -2931,6 +2932,7 @@ int uart_match_port(struct uart_port *po
+@@ -2932,6 +2933,7 @@ int uart_match_port(struct uart_port *po
        case UPIO_HUB6:
                return (port1->iobase == port2->iobase) &&
                       (port1->hub6   == port2->hub6);