ipq806x: improve model name and revision for TP-Link AD7200
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Wed, 6 Jan 2021 13:00:58 +0000 (14:00 +0100)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Wed, 6 Jan 2021 13:43:12 +0000 (14:43 +0100)
The TP-Link AD7200 appears with and without the "Talon" model name
prefix. Let's use both variants for 'make menuconfig' so everybody
can locate the device.

Concerning the revision, the TP-Link page lists v1 and v2 with the
device currently marked as "End of Life". However, the v2 and latest
v1 firmware are byte-identical. Thus, we only need one image for
this device and do not need to include the revision in the image name.

While at it, remove the useless BOARD_NAME variable which only makes
sense in combination with upgrade from legacy stable versions or when
custom upgrade scripts are involved.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/ipq806x/image/Makefile

index b0067574788cbeb53ec69b22bcbd60374edab93a..b77c0a99c005c7ae33bad37fcf94614325898391 100644 (file)
@@ -336,12 +336,14 @@ TARGET_DEVICES += qcom_ipq8064-db149
 define Device/tplink_ad7200
        $(call Device/TpSafeImage)
        DEVICE_VENDOR := TP-Link
-       DEVICE_MODEL := Talon AD7200
-       DEVICE_VARIANT := v1
+       DEVICE_MODEL := AD7200
+       DEVICE_VARIANT := v1/v2
+       DEVICE_ALT0_VENDOR := TP-Link
+       DEVICE_ALT0_MODEL := Talon AD7200
+       DEVICE_ALT0_VARIANT := v1/v2
        SOC := qcom-ipq8064
        BLOCKSIZE := 128k
        PAGESIZE := 2048
-       BOARD_NAME := ad7200
        TPLINK_BOARD_ID := AD7200
        DEVICE_PACKAGES := ath10k-firmware-qca99x0-ct kmod-wil6210
 endef