Revert "ramips: fix flash layout for TP-Link TL-WR841N v14"
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Wed, 22 Jul 2020 16:49:09 +0000 (18:49 +0200)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Wed, 22 Jul 2020 16:59:44 +0000 (18:59 +0200)
This reverts commit 1623defbdbb852a4018329d07673b4b8f66225a8.

As already stated in the reverted patch, the OEM firmware will
properly recreate the config partition if it is overwritten by
OpenWrt.

The main reason for adding the partition was the image size
restriction imposed by the 0x3d0000 limitation of the TFTP
flashing process. Addressing this by shrinking the firmware
partition is not a good solution to that problem, though:

1. For a working image, the size of the content has to be smaller
   than the available space, so empty erase blocks will remain.

2. Conceptually, the restriction is on the image, so it makes sense
   to implement it in the same way, and not via the partitioning.
   Users could e.g. do initial flash with TFTP restriction with
   an older image, and then sysupgrade into a newer one, so TFTP
   restriction does not apply.

3. The (content) size of the recovery image is enforced to 0x3d0000
   by the tplink-v2-image command in combination with
   TPLINK_FLASHLAYOUT (flash layout in mktplinkfw2.c) anyway.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/ramips/dts/mt7628an_tplink_tl-wr841n-v14.dts
target/linux/ramips/image/mt76x8.mk

index 885e069b02877a72c323d6bd8009f98954f2fc4e..b33c2ecae82ac39e48e0b6d88d04071c7a0b26b4 100644 (file)
                        partition@10000 {
                                compatible = "tplink,firmware";
                                label = "firmware";
-                               reg = <0x10000 0x3d0000>;
-                       };
-
-                       partition@3e0000 {
-                               label = "config";
-                               reg = <0x3e0000 0x10000>;
-                               read-only;
+                               reg = <0x10000 0x3e0000>;
                        };
 
                        factory: partition@3f0000 {
index c9e70b76721b2d2e227b86913777f483a2fc43ac..4b2255bd6ac38db496df53be3c18dbc61250efd8 100644 (file)
@@ -498,7 +498,7 @@ TARGET_DEVICES += tplink_tl-wr841n-v13
 
 define Device/tplink_tl-wr841n-v14
   $(Device/tplink-v2)
-  IMAGE_SIZE := 3904k
+  IMAGE_SIZE := 3968k
   DEVICE_MODEL := TL-WR841N
   DEVICE_VARIANT := v14
   TPLINK_FLASHLAYOUT := 4Mmtk