ath79: fix rootfs padding for D-Link DAP-2xxx
authorSebastian Schaper <openwrt@sebastianschaper.net>
Wed, 22 Jun 2022 21:38:26 +0000 (23:38 +0200)
committerChristian Lamparter <chunkeey@gmail.com>
Fri, 24 Jun 2022 22:05:21 +0000 (00:05 +0200)
It was observed that `rootfs_data` was sometimes not correctly erased
after performing sysupgrade, resulting in previous settings to prevail.

Add call to `wrgg-pad-rootfs` in sysupgrade image recipe to ensure any
previous jffs2 will be wiped, consistent with DAP-2610 from the ipq40xx
target, which introduced the double-flashing procedure for these devices.

Signed-off-by: Sebastian Schaper <openwrt@sebastianschaper.net>
(cherry picked from commit f770c33d7bb94b610d3a1c1fa84bc917678b65bc)

target/linux/ath79/image/generic.mk

index 5f8fc922da5fa2feeb4e10aa94bb0413e4f18c99..c4b810cb59a6fd9758fabc7e9f60217a7b2d6314 100644 (file)
@@ -862,7 +862,8 @@ define Device/dlink_dap-2xxx
   IMAGE/factory.img := append-kernel | pad-offset 6144k 160 | \
        append-rootfs | wrgg-pad-rootfs | mkwrggimg | check-size
   IMAGE/sysupgrade.bin := append-kernel | mkwrggimg | \
-       pad-to $$$$(BLOCKSIZE) | append-rootfs | check-size | append-metadata
+       pad-to $$$$(BLOCKSIZE) | append-rootfs | wrgg-pad-rootfs | \
+       check-size | append-metadata
   KERNEL := kernel-bin | append-dtb | relocate-kernel | lzma
   KERNEL_INITRAMFS := $$(KERNEL) | mkwrggimg
 endef