imx6: rename Generic profile to Default, fixes u-boot image build issue
authorFelix Fietkau <nbd@nbd.name>
Wed, 5 Sep 2018 07:52:57 +0000 (09:52 +0200)
committerFelix Fietkau <nbd@nbd.name>
Wed, 5 Sep 2018 08:00:01 +0000 (10:00 +0200)
u-boot.mk checks for the Default profile to build images for all targets.
This brings the target default profile in sync with other targets

Signed-off-by: Felix Fietkau <nbd@nbd.name>
target/linux/imx6/profiles/100-default.mk [new file with mode: 0644]
target/linux/imx6/profiles/100-generic.mk [deleted file]

diff --git a/target/linux/imx6/profiles/100-default.mk b/target/linux/imx6/profiles/100-default.mk
new file mode 100644 (file)
index 0000000..60b3ef5
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Default
+  PRIORITY:=1
+  NAME:=Default Profile
+endef
+
+define Profile/Default/Description
+ Package set compatible with most Freescale i.MX 6 based boards.
+endef
+
+$(eval $(call Profile,Default))
diff --git a/target/linux/imx6/profiles/100-generic.mk b/target/linux/imx6/profiles/100-generic.mk
deleted file mode 100644 (file)
index 218cd69..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-#
-# Copyright (C) 2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Generic
-  PRIORITY:=1
-  NAME:=Generic (default)
-endef
-
-define Profile/Generic/Description
- Package set compatible with most Freescale i.MX 6 based boards.
-endef
-
-$(eval $(call Profile,Generic))