Add support for the network packet generator
authorFlorian Fainelli <florian@openwrt.org>
Tue, 2 Oct 2007 11:10:29 +0000 (11:10 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 2 Oct 2007 11:10:29 +0000 (11:10 +0000)
SVN-Revision: 9091

package/kernel/modules/network.mk

index e19f710b80b83b307075dbd6309fda36fd8948d9..32994c9e6de0c45159fa7d6bd567cd93ba52565c 100644 (file)
@@ -458,6 +458,22 @@ endef
 $(eval $(call KernelPackage,mp-alg))
 
 
+define KernelPackage/pktgen
+  SUBMENU:=$(NETWORK_SUPPORT_MENU)
+  TITLE:=Network packet generator
+  DEPENDS:=@LINUX_2_6
+  KCONFIG:=CONFIG_NET_PKTGEN
+  FILES:=$(LINUX_DIR)/net/core/pktgen.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,99,pktgen)
+endef
+
+define KernelPackage/pktgen/description
+  Kernel modules for the Network Packet Generator
+endef
+
+$(eval $(call KernelPackage,pktgen))
+
+
 NETWORK_DEVICES_MENU:=Network Devices
 
 define KernelPackage/natsemi