brcm47xx: BGMAC - Adjust AutoLoad number to be prior to switch modules
authorHauke Mehrtens <hauke@hauke-m.de>
Sat, 16 Feb 2013 16:27:33 +0000 (16:27 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 16 Feb 2013 16:27:33 +0000 (16:27 +0000)
Adjust the "AutoLoad" number for the BGMAC module to be prior
to the switch modules.  This probably isn't real important as
the modules are loaded in the correct order by preinit anyway.

Signed-off-by: Nathan Hintz <nlhintz@hotmail.com>
SVN-Revision: 35625

target/linux/brcm47xx/modules.mk

index 2ea637df05d6cde16dcfa37dfc060b463a155ffe..458c1ea5e4bf7b35373f4b9a486f44f41ed3a533 100644 (file)
@@ -43,7 +43,7 @@ define KernelPackage/bgmac
   DEPENDS:=@TARGET_brcm47xx
   SUBMENU:=$(NETWORK_DEVICES_MENU)
   FILES:=$(LINUX_DIR)/drivers/net/ethernet/broadcom/bgmac.ko
-  AUTOLOAD:=$(call AutoLoad,50,bgmac)
+  AUTOLOAD:=$(call AutoLoad,19,bgmac)
 endef
 
 define KernelPackage/bgmac/description