update to newer snapshots, avoid 404 errors durring build
authorMike Baker <mbm@openwrt.org>
Sun, 19 Sep 2004 05:12:19 +0000 (05:12 +0000)
committerMike Baker <mbm@openwrt.org>
Sun, 19 Sep 2004 05:12:19 +0000 (05:12 +0000)
SVN-Revision: 160

obsolete-buildroot/Makefile
obsolete-buildroot/make/uclibc.mk
obsolete-buildroot/sources/openwrt/kernel/diag.c
obsolete-buildroot/sources/uClibc-sigaction.patch [deleted file]

index a8ea374c37d27028815f107576c4f69d18c36b69..859bda478c39359a3736886fe571dade7f5aa786 100644 (file)
@@ -28,7 +28,7 @@
 #
 #############################################################
 
-SNAPSHOT:=20040807
+SNAPSHOT:=20040916
 
 ARCH:=mipsel
 USE_UCLIBC_SNAPSHOT:=$(SNAPSHOT)
index 44bff70a92a27d373b2d93f00f685ad0ba7f5741..1e18d6894b2c8eae40307ffe7ade77e0258f08e7 100644 (file)
@@ -47,7 +47,6 @@ endif
 ifeq ($(strip $(USE_UCLIBC_LDSO_0_9_24)),true)
        $(SOURCE_DIR)/patch-kernel.sh $(UCLIBC_DIR) $(SOURCE_DIR) uClibc-ldso-0.9.24.patch
 endif
-       $(SOURCE_DIR)/patch-kernel.sh $(UCLIBC_DIR) $(SOURCE_DIR) uClibc-sigaction.patch
        touch $(UCLIBC_DIR)/.unpacked
 
 $(UCLIBC_DIR)/.configured: $(UCLIBC_DIR)/.unpacked $(LINUX_DIR)/.configured
index 1fe2baf5d24f79150436ba6c88002e5a15821db8..d39ac7c698c335486dd29c2b1b08510bedbd8f17 100644 (file)
@@ -167,16 +167,16 @@ static int __init diag_init()
                        }
                } else if (!strcmp(buf,"bcm94710ap")) {
                        buf=nvram_get("boardnum")?:"";
-                       if (!strcmp(buf,"44")) {
-                               //dell truemobile
-                               set_dmz=v2_set_dmz;
-                               reset_gpio=(1<<0);
-                               reset_polarity=0;
-                       } else {
+                       if (!strcmp(buf,"42")) {
                                // buffalo
                                set_dmz=v2_set_dmz;
                                reset_gpio=(1<<4);
                                reset_polarity=1;
+                       } else if (!strcmp(buf,"44")) {
+                               //dell truemobile
+                               set_dmz=v2_set_dmz;
+                               reset_gpio=(1<<0);
+                               reset_polarity=0;
                        }
                }
        } else {
diff --git a/obsolete-buildroot/sources/uClibc-sigaction.patch b/obsolete-buildroot/sources/uClibc-sigaction.patch
deleted file mode 100644 (file)
index 6440b59..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- uClibc/libc/sysdeps/linux/mips/Makefile    17 Jul 2004 00:39:14 -0000      1.41
-+++ uClibc/libc/sysdeps/linux/mips/Makefile    9 Aug 2004 03:33:14 -0000
-@@ -28,7 +28,7 @@
- SOBJS=$(patsubst %.S,%.o, $(SSRC))
- CSRC=__longjmp.c  brk.c setjmp_aux.c mmap.c __syscall_error.c \
--      cacheflush.c pread_write.c sysmips.c _test_and_set.c sigaction.c
-+      cacheflush.c pread_write.c sysmips.c _test_and_set.c
- COBJS=$(patsubst %.c,%.o, $(CSRC))
- OBJS=$(SOBJS) $(MOBJ) $(COBJS)