kernel: bump 4.14 to 4.14.275
authorPetr Štetiar <ynezz@true.cz>
Tue, 5 Apr 2022 12:20:05 +0000 (14:20 +0200)
committerPetr Štetiar <ynezz@true.cz>
Tue, 5 Apr 2022 12:20:05 +0000 (14:20 +0200)
All patches refreshed automagically without conflicts.

Run tested on ipq40xx/glinet-b1300 and mvebu/turris-omnia.

Signed-off-by: Petr Štetiar <ynezz@true.cz>
include/kernel-version.mk
target/linux/bcm53xx/patches-4.14/905-BCM53573-minor-hacks.patch
target/linux/sunxi/patches-4.14/031-arm64-Implement-arch_counter_get_cntpct-to-read-the-.patch
target/linux/sunxi/patches-4.14/100-clocksource-drivers-arch_timer-Workaround-for-Allwin.patch

index d0ac3b2ee1e64fe8c933d53f0763265745b0ce19..1d97de0ec044d4118bbe1888b9d643ea98029fed 100644 (file)
@@ -6,9 +6,9 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-4.14 = .274
+LINUX_VERSION-4.14 = .275
 
-LINUX_KERNEL_HASH-4.14.274 = 2b42538fcb88df5113e1797ab18252ac6ba876f1d13c83af6ea7c6430b0f7fad
+LINUX_KERNEL_HASH-4.14.275 = 100a9960fb2d8e079c9feeef640715a7fb749ed728a57e427f9e2443212e58f9
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 4762505708e6cbecd164f32965503064e2ee4c54..a0a893a31fec2ccba8bb45c391d60aa2300dde75 100644 (file)
@@ -61,7 +61,7 @@ Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
  #include <linux/clockchips.h>
  #include <linux/clocksource.h>
  #include <linux/interrupt.h>
-@@ -845,6 +846,16 @@ static void arch_timer_of_configure_rate
+@@ -860,6 +861,16 @@ static void arch_timer_of_configure_rate
        if (of_property_read_u32(np, "clock-frequency", &arch_timer_rate))
                arch_timer_rate = rate;
  
index 60f0cb6c9b90a56564b4ae85e40402f0ca4674ce..937d3e591e5cc89331f3bd1b2811421471edf206 100644 (file)
@@ -84,7 +84,7 @@ Signed-off-by: Christoffer Dall <christoffer.dall@linaro.org>
  static u64 notrace arm64_858921_read_cntvct_el0(void)
  {
        u64 old, new;
-@@ -346,6 +365,7 @@ static const struct arch_timer_erratum_w
+@@ -353,6 +372,7 @@ static const struct arch_timer_erratum_w
                .desc = "Freescale erratum a005858",
                .read_cntp_tval_el0 = fsl_a008585_read_cntp_tval_el0,
                .read_cntv_tval_el0 = fsl_a008585_read_cntv_tval_el0,
@@ -92,7 +92,7 @@ Signed-off-by: Christoffer Dall <christoffer.dall@linaro.org>
                .read_cntvct_el0 = fsl_a008585_read_cntvct_el0,
                .set_next_event_phys = erratum_set_next_event_tval_phys,
                .set_next_event_virt = erratum_set_next_event_tval_virt,
-@@ -358,6 +378,7 @@ static const struct arch_timer_erratum_w
+@@ -365,6 +385,7 @@ static const struct arch_timer_erratum_w
                .desc = "HiSilicon erratum 161010101",
                .read_cntp_tval_el0 = hisi_161010101_read_cntp_tval_el0,
                .read_cntv_tval_el0 = hisi_161010101_read_cntv_tval_el0,
@@ -100,7 +100,7 @@ Signed-off-by: Christoffer Dall <christoffer.dall@linaro.org>
                .read_cntvct_el0 = hisi_161010101_read_cntvct_el0,
                .set_next_event_phys = erratum_set_next_event_tval_phys,
                .set_next_event_virt = erratum_set_next_event_tval_virt,
-@@ -368,6 +389,7 @@ static const struct arch_timer_erratum_w
+@@ -375,6 +396,7 @@ static const struct arch_timer_erratum_w
                .desc = "HiSilicon erratum 161010101",
                .read_cntp_tval_el0 = hisi_161010101_read_cntp_tval_el0,
                .read_cntv_tval_el0 = hisi_161010101_read_cntv_tval_el0,
@@ -108,7 +108,7 @@ Signed-off-by: Christoffer Dall <christoffer.dall@linaro.org>
                .read_cntvct_el0 = hisi_161010101_read_cntvct_el0,
                .set_next_event_phys = erratum_set_next_event_tval_phys,
                .set_next_event_virt = erratum_set_next_event_tval_virt,
-@@ -378,6 +400,7 @@ static const struct arch_timer_erratum_w
+@@ -385,6 +407,7 @@ static const struct arch_timer_erratum_w
                .match_type = ate_match_local_cap_id,
                .id = (void *)ARM64_WORKAROUND_858921,
                .desc = "ARM erratum 858921",
index 6da300312fc78917b1634065b666923bf70fc6ae..79e94c6fd24a69be9de2a140960f21536a7c66a9 100644 (file)
@@ -173,7 +173,7 @@ Signed-off-by: Daniel Lezcano <daniel.lezcano@linaro.org>
        select TIMER_OF if OF
 --- a/drivers/clocksource/arm_arch_timer.c
 +++ b/drivers/clocksource/arm_arch_timer.c
-@@ -317,6 +317,48 @@ static u64 notrace arm64_858921_read_cnt
+@@ -324,6 +324,48 @@ static u64 notrace arm64_1188873_read_cn
  }
  #endif
  
@@ -222,8 +222,8 @@ Signed-off-by: Daniel Lezcano <daniel.lezcano@linaro.org>
  #ifdef CONFIG_ARM_ARCH_TIMER_OOL_WORKAROUND
  DEFINE_PER_CPU(const struct arch_timer_erratum_workaround *,
               timer_unstable_counter_workaround);
-@@ -404,6 +446,19 @@ static const struct arch_timer_erratum_w
-               .read_cntvct_el0 = arm64_858921_read_cntvct_el0,
+@@ -419,6 +461,19 @@ static const struct arch_timer_erratum_w
+               .read_cntvct_el0 = arm64_1188873_read_cntvct_el0,
        },
  #endif
 +#ifdef CONFIG_SUN50I_ERRATUM_UNKNOWN1