remove intrusive patch and find-a-better-way-to-do-it (tm)
authorNicolas Thill <nico@openwrt.org>
Mon, 1 May 2006 11:29:52 +0000 (11:29 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 1 May 2006 11:29:52 +0000 (11:29 +0000)
SVN-Revision: 3720

openwrt/package/lighttpd/Makefile
openwrt/package/lighttpd/patches/501-libxml2_includes.patch [deleted file]

index 5b53d33a12a674b8c6ef621623f904b4d47a2ed3..d0a88a65a2d700fb59b1c20b006597975743592f 100644 (file)
@@ -65,7 +65,7 @@ $(PKG_BUILD_DIR)/.configured:
        (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS)" \
-               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include/libxml2 -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
                PCRE_LIB="-lpcre" \
                PKG_CONFIG_PATH="$(STAGING_DIR)/usr/lib/pkgconfig" \
@@ -111,7 +111,6 @@ $(PKG_BUILD_DIR)/.built:
        rm -rf $(PKG_INSTALL_DIR)
        mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               STAGING_DIR=$(STAGING_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
        touch $@
diff --git a/openwrt/package/lighttpd/patches/501-libxml2_includes.patch b/openwrt/package/lighttpd/patches/501-libxml2_includes.patch
deleted file mode 100644 (file)
index 4b7943d..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -urN lighttpd-1.4.11/src/Makefile.in lighttpd-1.4.11.new/src/Makefile.in
---- lighttpd-1.4.11/src/Makefile.in    2006-03-07 13:21:02.000000000 +0100
-+++ lighttpd-1.4.11.new/src/Makefile.in        2006-04-17 00:16:12.000000000 +0200
-@@ -409,7 +409,7 @@
- STRIP = @STRIP@
- U = @U@
- VERSION = @VERSION@
--XML_CFLAGS = @XML_CFLAGS@
-+XML_CFLAGS = -I$(STAGING_DIR)/usr/include/libxml2
- XML_LIBS = @XML_LIBS@
- Z_LIB = @Z_LIB@
- ac_ct_AR = @ac_ct_AR@