projects
/
openwrt
/
staging
/
mkresin.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
9e04019
)
imagebuilder: fix standalone operation
author
Jo-Philipp Wich
<jo@mein.io>
Tue, 12 Apr 2016 23:46:09 +0000
(
01:46
+0200)
committer
Jo-Philipp Wich
<jo@mein.io>
Tue, 12 Apr 2016 23:46:09 +0000
(
01:46
+0200)
Fix standalone ImageBuilders after the package layout rework.
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
target/imagebuilder/Makefile
patch
|
blob
|
history
diff --git
a/target/imagebuilder/Makefile
b/target/imagebuilder/Makefile
index 106ca3d6f2d4adcb55cd4bd2cfcca61836034c58..87f91ce07776e402a64d837a013025388aca3993 100644
(file)
--- a/
target/imagebuilder/Makefile
+++ b/
target/imagebuilder/Makefile
@@
-53,7
+53,8
@@
ifeq ($(CONFIG_IB_STANDALONE),)
cp "$(PACKAGE_DIR)/$$path" "$(PKG_BUILD_DIR)/packages/$$path"; \
done
else
- $(CP) $(PACKAGE_DIR) $(PKG_BUILD_DIR)/packages
+ $(INSTALL_DIR) $(PKG_BUILD_DIR)/packages
+ find $(wildcard $(PACKAGE_SUBDIRS)) -type f -name '*.ipk' -exec $(CP) {} $(PKG_BUILD_DIR)/packages/ \;
endif
$(CP) $(TOPDIR)/target/linux $(PKG_BUILD_DIR)/target/