image.mk: remove device_ from manifest filename
authorPaul Spooren <mail@aparcar.org>
Mon, 12 Aug 2019 09:08:33 +0000 (23:08 -1000)
committerDaniel Golle <daniel@makrotopia.org>
Tue, 13 Aug 2019 08:40:36 +0000 (10:40 +0200)
The manifest file is based on IMG_PREFIX and PROFILE_SANITIZED, whereas
the latter takes a string like DEVICE_8dev_carambola2 and sanitizes it.
This behaviour results in a useless "device_" profile-prefix in the
device manifest filename. Now uses *subst* to remove that.

Therefore this patch results more consistent device file names:

openwrt-ath79-generic-8dev_carambola2-initramfs-kernel.bin
openwrt-ath79-generic-8dev-carambola2.manifest
openwrt-ath79-generic-8dev_carambola2-squashfs-sysupgrade.bin

instead of a single file being called

openwrt-ath79-generic-device_8dev-carambola2.manifest

Signed-off-by: Paul Spooren <mail@aparcar.org>
include/image.mk

index e55ac22d0dcfca04f0053210d7d64ffef215c542..c6a6ab7993ffb702edf1cedb7f76b99493444af1 100644 (file)
@@ -106,7 +106,7 @@ define add_jffs2_mark
        echo -ne '\xde\xad\xc0\xde' >> $(1)
 endef
 
-PROFILE_SANITIZED := $(call sanitize,$(PROFILE))
+PROFILE_SANITIZED := $(call sanitize,$(subst DEVICE_,,$(PROFILE)))
 
 define split_args
 $(foreach data, \