uhub: link against librt when eglibc is enabled
authorFelix Fietkau <nbd@openwrt.org>
Fri, 29 Jun 2012 21:19:52 +0000 (21:19 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 29 Jun 2012 21:19:52 +0000 (21:19 +0000)
SVN-Revision: 32543

net/uhub/Makefile

index 17c43da15a6ab32baf7d48f0f23704b4f4b8c887..3837be8b45ef414885d227db4c81b8b696fd0aab 100644 (file)
@@ -21,7 +21,7 @@ define Package/uhub
   SUBMENU:=P2P
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libevent
+  DEPENDS:=+libevent +USE_EGLIBC:librt
   TITLE:=High performance ADC hub
   URL:=http://www.extatic.org/uhub/
 endef
@@ -32,6 +32,10 @@ define Package/uhub/description
         on high-end servers, or a small private hub on embedded hardware.
 endef
 
+ifdef CONFIG_USE_EGLIBC
+TARGET_LDFLAGS += -lrt
+endif
+
 define Package/uhub/install
        $(INSTALL_DIR) $(1)/usr/local/bin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/uhub $(1)/usr/local/bin/