looks like not wbx is the only one who can forget a file ;)
authorImre Kaloz <kaloz@openwrt.org>
Sat, 2 Apr 2005 16:48:05 +0000 (16:48 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Sat, 2 Apr 2005 16:48:05 +0000 (16:48 +0000)
SVN-Revision: 523

openwrt/target/squashfs-lzma/squashfs2.0-tools-lzma.patch [new file with mode: 0644]

diff --git a/openwrt/target/squashfs-lzma/squashfs2.0-tools-lzma.patch b/openwrt/target/squashfs-lzma/squashfs2.0-tools-lzma.patch
new file mode 100644 (file)
index 0000000..324f8d8
--- /dev/null
@@ -0,0 +1,22 @@
+--- squashfs2.0/squashfs-tools/Makefile        2004-04-30 19:29:35.000000000 +0400
++++ squashfs-tools/Makefile    2005-01-20 14:57:53.423668596 +0300
+@@ -1,12 +1,18 @@
+ INCLUDEDIR = .
++#LZMAPATH = ../lzma/SRC/7zip/Compress/LZMA_Lib
+ CFLAGS := -I$(INCLUDEDIR) -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -O2
+ mksquashfs: mksquashfs.o read_fs.o sort.o
+       $(CC) mksquashfs.o read_fs.o sort.o -lz -o $@
++mksquashfs-lzma: mksquashfs.o read_fs.o sort.o
++      $(CXX) mksquashfs.o read_fs.o sort.o -L$(LZMAPATH) -llzma -o $@
++
+ mksquashfs.o: mksquashfs.c mksquashfs.h
+ read_fs.o: read_fs.c read_fs.h
+ sort.o: sort.c
++
++clean:
++      rm -f *.o mksquashfs mksquashfs-lzma