uci: only use $(FPIC) on library parts, saves a few hundred bytes
authorFelix Fietkau <nbd@openwrt.org>
Tue, 20 Oct 2009 08:26:39 +0000 (08:26 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 20 Oct 2009 08:26:39 +0000 (08:26 +0000)
SVN-Revision: 18092

package/uci/Makefile

index e5e5231a554823077678b2bf2a190df214fe952c..b86a4fea16356e99b347a61a7fd77a819c4a7ca8 100644 (file)
@@ -53,13 +53,13 @@ endef
 define Build/Configure
 endef
 
-TARGET_CFLAGS += $(FPIC)
 UCI_MAKEOPTS = \
                $(TARGET_CONFIGURE_OPTS) \
                COPTS="$(TARGET_CFLAGS)" \
                DEBUG="$(DEBUG)" \
                VERSION="$(UCI_VERSION)" \
                CPPFLAGS="-I$(PKG_BUILD_DIR) $(TARGET_CPPFLAGS)" \
+               FPIC="$(FPIC)" \
                OS="Linux"
 
 # work around a nasty gcc bug