pdns-recursor: update to 4.4.2 14690/head
authorRosen Penev <rosenp@gmail.com>
Wed, 3 Feb 2021 07:46:12 +0000 (23:46 -0800)
committerRosen Penev <rosenp@gmail.com>
Mon, 8 Feb 2021 00:55:14 +0000 (16:55 -0800)
Enable reproducible.

Remove upstreamed patch.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
net/pdns-recursor/Makefile
net/pdns-recursor/patches/300-boost-173.patch [deleted file]

index cd49c0155302a041a636c75461c308b9a0de5e50..8bed4d288de7addd0c80e63eaa03d39ad49cb77a 100644 (file)
@@ -1,12 +1,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pdns-recursor
-PKG_VERSION:=4.4.1
-PKG_RELEASE:=1
+PKG_VERSION:=4.4.2
+PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=https://downloads.powerdns.com/releases/
-PKG_HASH:=f97fa34635d42c68acee5d4da9db0e5ff619fd49e62acace7b4bdb7ee3675698
+PKG_HASH:=b0b97f49848a1758b64bc0b99a596c1583ea525477193f3c01905f5163a4f5cf
 
 PKG_MAINTAINER:=James Taylor <james@jtaylor.id.au>
 PKG_LICENCE:=GPL-2.0-only
@@ -47,6 +47,7 @@ CONFIGURE_ARGS += \
        --without-libsodium \
        --with-protobuf \
        --without-net-snmp \
+       --enable-reproducible \
        --disable-silent-rules
 
 CONFIGURE_VARS += \
diff --git a/net/pdns-recursor/patches/300-boost-173.patch b/net/pdns-recursor/patches/300-boost-173.patch
deleted file mode 100644 (file)
index ff89f5b..0000000
+++ /dev/null
@@ -1,21 +0,0 @@
---- a/webserver.cc
-+++ b/webserver.cc
-@@ -36,6 +36,8 @@
- #include "uuid-utils.hh"
- #include <yahttp/router.hpp>
-+using namespace boost::placeholders;
-+
- json11::Json HttpRequest::json()
- {
-   string err;
---- a/ws-recursor.cc
-+++ b/ws-recursor.cc
-@@ -46,6 +46,7 @@
- extern thread_local FDMultiplexer* t_fdm;
-+using namespace boost::placeholders;
- using json11::Json;
- void productServerStatisticsFetch(map<string,string>& out)