ntpd: cleanup Makefile and hotplug script
authorPeter Wagner <tripolar@gmx.at>
Tue, 17 Jan 2017 22:49:20 +0000 (23:49 +0100)
committerJo-Philipp Wich <jo@mein.io>
Sun, 5 Feb 2017 18:38:37 +0000 (19:38 +0100)
Signed-off-by: Peter Wagner <tripolar@gmx.at>
net/ntpd/Makefile
net/ntpd/files/ntpd.hotplug-helper

index e16669611c9e1d723de93229169b1fe55b9464fe..f1e57ad4ffa74ed40015651b749ba5d4e7a00131 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ntp
 PKG_VERSION:=4.2.8p9
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-4.2/
@@ -117,7 +117,7 @@ define Package/ntpd/install
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/ntpd/ntpd $(1)/sbin/
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/ntpq/ntpq $(1)/usr/sbin/
-       $(INSTALL_BIN) ./files/ntpd.hotplug-helper $(1)/usr/sbin/ntpd.hotplug-helper
+       $(INSTALL_BIN) ./files/ntpd.hotplug-helper $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc
        $(INSTALL_CONF) ./files/ntp.conf $(1)/etc/
        $(INSTALL_DIR) $(1)/etc/init.d
index 39d3df0f72135577686ca42db5a9f8c01bd291df..555825c64839514e3f15e55e0dc6d995422ed98b 100644 (file)
@@ -1,10 +1,8 @@
 #!/bin/sh
 
-HOTPLUG_SCRIPT=/usr/sbin/ntpd-hotplug
-
 while true
 do
-       STATUS="$(ntpq -c 'rv 0 stratum'|awk -F '=' '{ print $2 }')"
+       STATUS="$(/usr/sbin/ntpq -c 'rv 0 stratum'|awk -F '=' '{ print $2 }')"
 
        if [ -n "$STATUS" ] && [ "$STATUS" -lt "16" ]
        then