safe-search: fix use with dnsmasq in ujail
authorDaniel Golle <daniel@makrotopia.org>
Mon, 5 Dec 2022 00:51:14 +0000 (00:51 +0000)
committerDaniel Golle <daniel@makrotopia.org>
Sat, 14 Jan 2023 01:47:32 +0000 (01:47 +0000)
The safe-search package creates symlinks in a configured additional
hosts directory. The link targets are inside another directory which
has to be made available to dnsmasq as well.
Now that support for adding additional paths to dnsmasq was added by
commit openwrt/openwrt@aa12a0fdd1c5a004281633c5b0758da1781bb41c
implement adding this path using the existing uci-defaults script.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
net/safe-search/Makefile
net/safe-search/files/safe-search.defaults

index b8afee5d772f980962dfff9e90ec544a1f0fa83b..1492db09008edfb4c53af1dc3b4783faa98538b5 100644 (file)
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=safe-search
 PKG_VERSION:=2.0.1
-PKG_RELEASE:=$(AUTORELEASE)
+PKG_RELEASE:=11
 PKG_LICENSE:=MIT
 PKG_MAINTAINER:=Gregory L. Dietsche <Gregory.Dietsche@cuw.edu>
 
index 063e84cc38400317f06d5cb69064a486a7c2f76c..e7f4d052bd89f0b4cc3f7be60ddcb83449bed79a 100644 (file)
@@ -5,6 +5,8 @@
 #
 uci del_list dhcp.@dnsmasq[0].addnhosts=/etc/safe-search/enabled
 uci add_list dhcp.@dnsmasq[0].addnhosts=/etc/safe-search/enabled
+uci del_list dhcp.@dnsmasq[0].addn_mount=/etc/safe-search/available
+uci add_list dhcp.@dnsmasq[0].addn_mount=/etc/safe-search/available
 uci commit dhcp
 
 /usr/sbin/safe-search-maintenance