dovecot: add LDAP option 387/head
authorW. Michael Petullo <mike@flyn.org>
Wed, 1 Oct 2014 02:54:05 +0000 (22:54 -0400)
committerW. Michael Petullo <mike@flyn.org>
Wed, 1 Oct 2014 02:54:05 +0000 (22:54 -0400)
Signed-off-by: W. Michael Petullo <mike@flyn.org>
mail/dovecot/Makefile

index 1f6becff7c04f2404a571ee5d5d58269313c40d1..da1f1d41f768675c2b9ac9eddaa147e23fcefd4b 100644 (file)
@@ -27,7 +27,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/dovecot
   SECTION:=mail
   CATEGORY:=Mail
-  DEPENDS:=+libopenssl +librt +zlib +libbz2 +libcap
+  DEPENDS:=+DOVECOT_LDAP:libopenldap +libopenssl +librt +zlib +libbz2 +libcap
   TITLE:=An IMAP and POP3 daemon
   MAINTAINER:=Peter Wagner <tripolar@gmx.at>
   URL:=http://www.dovecot.org/
@@ -37,6 +37,17 @@ define Package/dovecot/description
  Dovecot is a program which provides POP3 and IMAP services.
 endef
 
+define Package/dovecot/config
+        menu "Select dovecot build options"
+                depends on PACKAGE_dovecot
+                config DOVECOT_LDAP
+                        bool "LDAP support"
+                        default y
+                        help
+                          Implements LDAP support in dovecot.
+        endmenu
+endef
+
 CONFIGURE_ARGS += \
        --without-gssapi \
        --without-pam \
@@ -45,6 +56,14 @@ CONFIGURE_ARGS += \
        --without-lzma \
        --without-lz4
 
+ifneq ($(strip $(CONFIG_DOVECOT_LDAP)),)
+  CONFIGURE_ARGS+= \
+       --with-ldap=yes
+else
+  CONFIGURE_ARGS+= \
+       --with-ldap=no
+endif
+
 CONFIGURE_VARS += \
        RPCGEN= \
        i_cv_signed_size_t=no \