Merge pull request #1985 from jefferyto/python-setuptools-host
authorHannu Nyman <hannu.nyman@iki.fi>
Sun, 6 Dec 2015 11:39:23 +0000 (13:39 +0200)
committerHannu Nyman <hannu.nyman@iki.fi>
Sun, 6 Dec 2015 11:39:23 +0000 (13:39 +0200)
python-setuptools: add ability to install on host

1  2 
lang/python-setuptools/Makefile

index 17b29fc0acd18adbf080b30a900f19029395ef35,fda4821b491c0d6359523eada32bd76b1d3dae02..27c26e8cc56159b8cc32fa713f5079ff81a6ba4c
@@@ -13,12 -13,17 +13,17 @@@ PKG_RELEASE:=
  
  PKG_SOURCE:=setuptools-$(PKG_VERSION).tar.gz
  PKG_SOURCE_URL:=https://pypi.python.org/packages/source/s/setuptools/
 -PKG_MD5SUM:=533c868f01169a3085177dffe5e768bb
 +PKG_MD5SUM:=295d7aaef2da7d6ff10b522581da0cf9
  
+ HOST_BUILD_DEPENDS:=python/host
  PKG_BUILD_DIR:=$(BUILD_DIR)/setuptools-$(PKG_VERSION)
+ HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/setuptools-$(PKG_VERSION)
  
+ include $(INCLUDE_DIR)/host-build.mk
  include $(INCLUDE_DIR)/package.mk
  $(call include_mk, python-package.mk)
+ $(call include_mk, python-host.mk)
  
  define Package/python-setuptools
    SUBMENU:=Python