beanstald: fix compilation under macOS
authorRosen Penev <rosenp@gmail.com>
Mon, 4 Oct 2021 22:51:58 +0000 (15:51 -0700)
committerRosen Penev <rosenp@gmail.com>
Fri, 8 Oct 2021 16:43:28 +0000 (09:43 -0700)
Makefile tests the host system, not what it compiles to. Override.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
net/beanstalkd/Makefile

index 3bedb09bc9e4ba5c304034b63b8db0c64fd82147..97c2608eb572ca9a7a5b5a637f44bca392f91add 100644 (file)
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=beanstalkd
 PKG_VERSION:=1.9
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 # for now, build from latest commit since releases are infrequent and
 # useful fixes trickle in...
@@ -37,7 +37,7 @@ define Build/Configure
 endef
 
 define Build/Compile
-       cd $(PKG_BUILD_DIR) && make CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS)" LDFLAGS="$(TARGET_LDFLAGS)" PREFIX=/usr
+       cd $(PKG_BUILD_DIR) && make CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS)" LDFLAGS="$(TARGET_LDFLAGS)" PREFIX=/usr OS=linux
 endef
 
 define Package/beanstalkd/install