Enable the host tools on protobuf-c (protoc-c specifically)
authorMike Kershaw / Dragorn <dragorn@kismetwireless.net>
Mon, 30 Apr 2018 21:14:47 +0000 (17:14 -0400)
committerRosen Penev <rosenp@gmail.com>
Fri, 24 Jan 2020 07:22:58 +0000 (23:22 -0800)
Signed-Off-By: Mike Kershaw <dragorn@kismetwireless.net>
(cherry-picked from 6915059e35d74f8daede429df74d9635b2a6c9f0)

libs/protobuf-c/Makefile

index e2d17c06ee160fd7aa0275110880d0ea875a1202..769cea9b501152ba7c02950bbe938db8bf627c13 100644 (file)
@@ -17,6 +17,8 @@ PKG_SOURCE_URL:=https://github.com/protobuf-c/protobuf-c.git
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_VERSION:=$(PKG_VERSION)
 
+PKG_BUILD_DEPENDS:=protobuf-c/host
+
 PKG_INSTALL:=1
 PKG_FIXUP:=autoreconf
 
@@ -25,6 +27,7 @@ PKG_LICENSE:=BSD-2c
 PKG_MAINTAINER:=Jacob Siverskog <jacob@teenageengineering.com>
 
 include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/host-build.mk
 
 define Package/libprotobuf-c
   TITLE:=Protocol Buffers library
@@ -60,3 +63,5 @@ define Package/libprotobuf-c/install
 endef
 
 $(eval $(call BuildPackage,libprotobuf-c))
+$(eval $(call HostBuild))
+