lighttpd: update to lighttpd 1.4.61 release hash
authorGlenn Strauss <gstrauss@gluelogic.com>
Fri, 29 Oct 2021 01:51:44 +0000 (21:51 -0400)
committerRosen Penev <rosenp@gmail.com>
Sat, 30 Oct 2021 08:05:07 +0000 (01:05 -0700)
also remove patches incorporated upstream into lighttpd 1.4.61

Signed-off-by: Glenn Strauss <gstrauss@gluelogic.com>
net/lighttpd/Makefile
net/lighttpd/files/lighttpd.conf
net/lighttpd/patches/010-meson-lua.patch
net/lighttpd/patches/020-decls.patch [deleted file]

index 7286db3858985e20452444cea520a5313eb08acb..8e6687d81cf9597dd770f3b18f51206c6597f77a 100644 (file)
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=lighttpd
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=lighttpd
-PKG_VERSION:=1.4.60
+PKG_VERSION:=1.4.61
 PKG_RELEASE:=1
 # release candidate ~rcX testing; remove for release
 PKG_RELEASE:=1
 # release candidate ~rcX testing; remove for release
-#PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-1.4.60
+#PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-1.4.61
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://download.lighttpd.net/lighttpd/releases-1.4.x
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://download.lighttpd.net/lighttpd/releases-1.4.x
-PKG_HASH:=4bb1dd859e541a3131e5be101557d2e1195b4129d3a849a3a6fbd21fe1c946f0
+PKG_HASH:=43f0d63d04a1b7c5b8aab07e0612e44ccad0afc0614bab784c5b019872363432
 
 PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
 PKG_LICENSE:=BSD-3-Clause
 
 PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
 PKG_LICENSE:=BSD-3-Clause
index 079d2a6884cf77b4795a6d9161c7807aa078aeda..64640779faa1e1f0bc87ea654ac739fde46474d2 100644 (file)
@@ -28,7 +28,7 @@ server.feature-flags       += ("server.graceful-shutdown-timeout" => 5)
 #include_shell "/usr/share/lighttpd/use-ipv6.pl"
 
 #dir-listing.encoding        = "utf-8"
 #include_shell "/usr/share/lighttpd/use-ipv6.pl"
 
 #dir-listing.encoding        = "utf-8"
-#server.dir-listing          = "enable"
+#dir-listing.activate        = "enable"
 
 include "/etc/lighttpd/mime.conf"
 include "/etc/lighttpd/conf.d/*.conf"
 
 include "/etc/lighttpd/mime.conf"
 include "/etc/lighttpd/conf.d/*.conf"
index 52e98e68e8376df727e4d236443bdce0ce42e712..b67795ea1b0345776a77dc626d083fb30aae08e5 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: Glenn Strauss <gstrauss@gluelogic.com>
 
 --- a/src/meson.build
 +++ b/src/meson.build
 
 --- a/src/meson.build
 +++ b/src/meson.build
-@@ -388,7 +388,7 @@ endif
+@@ -390,7 +390,7 @@ endif
  liblua = []
  if get_option('with_lua')
        found_lua = false
  liblua = []
  if get_option('with_lua')
        found_lua = false
diff --git a/net/lighttpd/patches/020-decls.patch b/net/lighttpd/patches/020-decls.patch
deleted file mode 100644 (file)
index c1d15cf..0000000
+++ /dev/null
@@ -1,34 +0,0 @@
-From cf4dfbe15ef8ead3a7eda974af7d804d447f00db Mon Sep 17 00:00:00 2001
-From: Glenn Strauss <gstrauss@gluelogic.com>
-Date: Mon, 4 Oct 2021 09:51:22 -0400
-Subject: [PATCH] [core] define __BEGIN_DECLS, __END_DECLS if needed
-
----
- src/first.h | 16 ++++++++++++++++
- 1 file changed, 16 insertions(+)
-
---- a/src/first.h
-+++ b/src/first.h
-@@ -39,6 +39,22 @@
- #include <sys/types.h>
- #include <stddef.h>
-+#ifndef __BEGIN_DECLS
-+#ifdef __cplusplus
-+#define __BEGIN_DECLS extern "C" {
-+#else
-+#define __BEGIN_DECLS
-+#endif
-+#endif
-+
-+#ifndef __END_DECLS
-+#ifdef __cplusplus
-+#define __END_DECLS }
-+#else
-+#define __END_DECLS
-+#endif
-+#endif
-+
- #if defined HAVE_STDINT_H
- # include <stdint.h>
- #elif defined HAVE_INTTYPES_H