nginx: support gzip static mudule
authorJianhui Zhao <zhaojh329@gmail.com>
Wed, 27 Jul 2022 15:03:19 +0000 (23:03 +0800)
committerRosen Penev <rosenp@gmail.com>
Wed, 24 Aug 2022 05:19:07 +0000 (22:19 -0700)
Signed-off-by: Jianhui Zhao <zhaojh329@gmail.com>
net/nginx/Config_ssl.in
net/nginx/Makefile

index 1c53dab6aa6b6a9768e39e64f011b2350d680aec..df54624d3d7fa45a5bc6fe011fe896ba0efa03e6 100644 (file)
@@ -46,6 +46,11 @@ config NGINX_HTTP_GZIP
        prompt "Enable HTTP gzip module"
        default y
 
+config NGINX_HTTP_GZIP_STATIC
+       bool
+       prompt "Enable HTTP gzip static module"
+       default y
+
 config NGINX_HTTP_SSI
        bool
        prompt "Enable HTTP ssi module"
index 340de5846f0de40a72b2054ee3b4eca824cfc743..41436aa39676a5c150514c566cab7ebab974b273 100644 (file)
@@ -31,6 +31,7 @@ PKG_CONFIG_DEPENDS := \
        CONFIG_NGINX_STUB_STATUS \
        CONFIG_NGINX_HTTP_CHARSET \
        CONFIG_NGINX_HTTP_GZIP \
+       CONFIG_NGINX_HTTP_GZIP_STATIC \
        CONFIG_NGINX_HTTP_SSI \
        CONFIG_NGINX_HTTP_USERID \
        CONFIG_NGINX_HTTP_ACCESS \
@@ -152,6 +153,9 @@ ifneq ($(BUILD_VARIANT),all-module)
   ifneq ($(CONFIG_NGINX_HTTP_GZIP),y)
     ADDITIONAL_MODULES += --without-http_gzip_module
   endif
+  ifeq ($(CONFIG_NGINX_HTTP_GZIP_STATIC),y)
+    ADDITIONAL_MODULES += --with-http_gzip_static_module
+  endif
   ifneq ($(CONFIG_NGINX_HTTP_SSI),y)
     ADDITIONAL_MODULES += --without-http_ssi_module
   endif