python,python3: add zlib/host to HOST_BUILD_DEPENDS (ver 2) 5342/head
authorAlexandru Ardelean <ardeleanalex@gmail.com>
Sun, 31 Dec 2017 16:39:42 +0000 (18:39 +0200)
committerAlexandru Ardelean <ardeleanalex@gmail.com>
Tue, 2 Jan 2018 16:59:53 +0000 (18:59 +0200)
This reverts commit 3c6d14021e62d68a7d9bdd4520b799c5c207fde1.
( which is a revert of commit c764f77dc1a62ce667b38520496ddb9bfaececab )

The initiall commit ( c764f77dc1a62ce667b38520496ddb9bfaececab )
was reverted, becase zlib did not have a host-build.

Now it does:
 https://github.com/openwrt/openwrt/commit/cbe71649bc49ccc6ae96385482d0794c33336f68

So, now it should be good to put this in.

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
lang/python/python/Makefile
lang/python/python3/Makefile

index b1bccfc8e42ca228588f0584469cc4a30e18c80a..5bab469e74640054acbb53607a1552373559d007 100644 (file)
@@ -12,9 +12,7 @@ include ./files/python-version.mk
 
 PKG_NAME:=python
 PKG_VERSION:=$(PYTHON_VERSION).$(PYTHON_VERSION_MICRO)
-# XXX: reset PKG_RELEASE to 1 only if Python's pip & setuptools versions have also bumped;
-#      otherwise, keep bumping PKG_RELEASE
-PKG_RELEASE:=6
+PKG_RELEASE:=7
 
 PKG_SOURCE:=Python-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://www.python.org/ftp/python/$(PKG_VERSION)
@@ -42,7 +40,7 @@ PKG_CONFIG_DEPENDS:= \
        CONFIG_PYTHON_BLUETOOTH_SUPPORT
 
 PKG_BUILD_DEPENDS:=python/host
-HOST_BUILD_DEPENDS:=bzip2/host expat/host
+HOST_BUILD_DEPENDS:=bzip2/host expat/host zlib/host
 
 include $(INCLUDE_DIR)/host-build.mk
 include $(INCLUDE_DIR)/package.mk
index 5193b160cbdc14bf1bab518cb9f4dce1b98dcd40..5c10442f3ac36483e6da1c71d52b897ce8476614 100644 (file)
@@ -14,7 +14,7 @@ PYTHON_VERSION:=$(PYTHON3_VERSION)
 PYTHON_VERSION_MICRO:=$(PYTHON3_VERSION_MICRO)
 
 PKG_NAME:=python3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_VERSION:=$(PYTHON_VERSION).$(PYTHON_VERSION_MICRO)
 
 PKG_SOURCE:=Python-$(PKG_VERSION).tar.xz
@@ -43,7 +43,7 @@ PKG_CONFIG_DEPENDS:= \
        CONFIG_PYTHON3_BLUETOOTH_SUPPORT
 
 PKG_BUILD_DEPENDS:=python3/host
-HOST_BUILD_DEPENDS:=bzip2/host expat/host libffi/host
+HOST_BUILD_DEPENDS:=bzip2/host expat/host libffi/host zlib/host
 
 include $(INCLUDE_DIR)/host-build.mk
 include $(INCLUDE_DIR)/package.mk