curl: update to 7.82.0 18004/head
authorStan Grishin <stangri@melmac.ca>
Sun, 6 Mar 2022 18:54:17 +0000 (18:54 +0000)
committerStan Grishin <stangri@melmac.ca>
Mon, 7 Mar 2022 02:57:42 +0000 (02:57 +0000)
* changelog: https://curl.se/changes.html#7_82_0

Signed-off-by: Stan Grishin <stangri@melmac.ca>
net/curl/Makefile
net/curl/patches/200-no_docs_tests.patch

index 8356645ee7cfc99ce5eefcd3d95e3a0c13b289f2..08ab67c2e60262d5fe05fbce9f34d19774ce0cd7 100644 (file)
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=curl
-PKG_VERSION:=7.81.0
+PKG_VERSION:=7.82.0
 PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://dl.uxnr.de/mirror/curl/ \
        https://curl.askapache.com/download/ \
        https://curl.se/download/
-PKG_HASH:=a067b688d1645183febc31309ec1f3cdce9213d02136b6a6de3d50f69c95a7d3
+PKG_HASH:=0aaa12d7bd04b0966254f2703ce80dd5c38dbbd76af0297d3d690cdce58a583c
 
 PKG_LICENSE:=MIT
 PKG_LICENSE_FILES:=COPYING
index 765b40d5879433df4c3f82b9257ac0df93bc7b40..274afc69876dd2d7ea685136e3b2976569ecc6cf 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Makefile.am
 +++ b/Makefile.am
-@@ -195,7 +195,7 @@ CLEANFILES = $(VC6_LIBDSP) $(VC6_SRCDSP)
+@@ -156,7 +156,7 @@ CLEANFILES = $(VC10_LIBVCXPROJ) $(VC10_S
  bin_SCRIPTS = curl-config
  
  SUBDIRS = lib src
@@ -9,7 +9,7 @@
  
  pkgconfigdir = $(libdir)/pkgconfig
  pkgconfig_DATA = libcurl.pc
-@@ -309,8 +309,6 @@ cygwinbin:
+@@ -270,8 +270,6 @@ cygwinbin:
  # We extend the standard install with a custom hook:
  install-data-hook:
        (cd include && $(MAKE) install)