rust: remove useless target dependencies and configuration
authorTianling Shen <cnsztl@immortalwrt.org>
Sun, 19 Mar 2023 05:43:06 +0000 (13:43 +0800)
committerTianling Shen <cnsztl@gmail.com>
Thu, 23 Mar 2023 18:08:47 +0000 (02:08 +0800)
They are for the target build which is not supported yet, drop them.

Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
lang/rust/Config.in [deleted file]
lang/rust/Makefile
lang/rust/rust_config.mk [deleted file]

diff --git a/lang/rust/Config.in b/lang/rust/Config.in
deleted file mode 100644 (file)
index 490322f..0000000
+++ /dev/null
@@ -1,95 +0,0 @@
-# Rust Language Options
-menu "Compiler Options"
-       visible if PACKAGE_rust
-
-       config RUST_DEBUG
-               bool "Enables Debugging Environment (--enable-debug)"
-
-       config RUST_DOCS
-               bool "Build standard library documentation (--enable-docs)"
-
-       config RUST_COMPILER_DOCS
-               bool "Build compiler documentation (--enable-compiler-docs)"
-
-       config RUST_OPTIMIZE_TESTS
-               bool "Build tests with optimizations (--enable-optimized-tests)"
-
-       config RUST_PARALLEL
-               bool "Build with multi-threaded support (--enable-parallel-compiler)"
-
-       config RUST_VERBOSE_TESTS
-               bool "Enable verbose output when running tests (--enable-verbose-tests)"
-
-       config RUST_CCACHE
-               bool "Build with ccache enabled (--enable-ccache)"
-
-       config RUST_LLVM_STATIC
-               bool "Statically link to libstdc++ to LLVM (--enable-llvm-static-stdccp)"
-
-       config RUST_LLVM_SHARED
-               bool "Prefer shared linking to LLVM (--enable-llvm-link-shared)"
-
-       config RUST_CODEGEN_TESTS
-               bool "Run the src/test/codegen tests (--enable-codegen-tests)"
-
-       config RUST_OPTION_CHECKING
-               bool "Complain about unrecognized options in this configure script (--enable-option-checking)"
-               default y
-
-       config RUST_ENABLE_NINJA
-               bool "Build LLVM using the Ninja generator (--enable-ninja)"
-               default y
-
-       config RUST_LOCKED_DEPS
-               bool "Force Cargo.lock to be up to date (--enable-locked-deps)"
-
-       config RUST_VENDOR
-               bool "Enable usage of vendored Rust crates (--enable-vendor)"
-
-       config RUST_SANITIZERS
-               bool "Build the sanitizer runtimes (asan, lsan, msan, tsan) (--enable-sanitizers)"
-
-       config RUST_DIST_SRC
-               bool "When building tarballs enables building a source tarball (--enable-dist-src)"
-
-       config RUST_CARGO_NATIVE_STATIC
-               bool "Build static native libraries in Cargo (--enable-cargo-native-static)"
-
-       config RUST_PROFILER
-               bool "Build the profiler runtime (--enable-profiler)"
-
-       config RUST_FULL_TOOLS
-               bool "Build all tools (--enable-full-tools)"
-
-       config RUST_MISSING_TOOLS
-               bool "Allow failures when building tools (--enable-missing-tools)"
-               default y
-
-       config RUST_USE_LIBCXX
-               bool "Build LLVM with libc++ (--enable-use-libcxx)"
-
-       config RUST_CONTROL_FLOW_GUARD
-               bool "Enable Control Flow Guard (--enable-control-flow-guard)"
-
-       config RUST_OPTIMIZE_LLVM
-               bool "Build optimized LLVM (--enable-optimize-llvm)"
-               default y
-
-       config RUST_LLVM_ASSERTIONS
-               bool "Build LLVM with assertions (--enable-llvm-assertions)"
-
-       config RUST_DEBUG_ASSERTIONS
-               bool "Build with debugging assertions (--enable-debug-assertions)"
-
-       config RUST_LLVM_RELEASE_DEBUGINFO
-               bool "Build LLVM with debugger metadata (--enable-llvm-release-debuginfo)"
-
-       config RUST_MANAGE_SUBMODULES
-               bool "Let the build manage the git submodules (--enable-manage-submodules)"
-               default y
-
-       config RUST_FULL_BOOTSTRAP
-               bool "Full Bootstrap - Build three compilers instead of two (--enable-full-bootstrap)"
-
-endmenu
-
index 104bb85108efcb3a19bed02ee1bf4eda2f2ed14c..f01e75e0b5b338603ab06bc4f197f3f38648bb0d 100644 (file)
@@ -30,8 +30,7 @@ define Package/rust
   SUBMENU:=Rust
   TITLE:=Rust Programming Language Compiler
   URL:=https://www.rust-lang.org/
-  DEPENDS:=$(RUST_ARCH_DEPENDS) \
-    +pkg-config +libunwind +libopenssl +liblzma +libc
+  DEPENDS:=$(RUST_ARCH_DEPENDS)
 endef
 
 define Package/rust/description
@@ -103,9 +102,5 @@ define Host/Install
        )
 endef
 
-define Package/rust/config
-       source "$(SOURCE)/Config.in"
-endef
-
 $(eval $(call HostBuild))
 $(eval $(call BuildPackage,rust))
diff --git a/lang/rust/rust_config.mk b/lang/rust/rust_config.mk
deleted file mode 100644 (file)
index 75017f8..0000000
+++ /dev/null
@@ -1,119 +0,0 @@
-ifeq ($(CONFIG_RUST_DEBUG),y)
-CONFIGURE_ARGS += --enable-debug
-endif
-
-ifeq ($(CONFIG_RUST_DOCS),y)
-CONFIGURE_ARGS += --enable-docs
-else
-CONFIGURE_ARGS += --disable-docs
-endif
-
-ifeq ($(CONFIG_RUST_COMPILER_DOCS),y)
-CONFIGURE_ARGS += --enable-compiler-docs
-else
-CONFIGURE_ARGS += --disable-compiler-docs
-endif
-
-ifeq ($(CONFIG_RUST_OPTIMIZE_TESTS),y)
-CONFIGURE_ARGS += --enable-optimize-tests
-endif
-
-ifeq ($(CONFIG_RUST_PARALLEL),y)
-CONFIGURE_ARGS += --enable-parallel-compiler
-endif
-
-ifeq ($(CONFIG_RUST_VERBOSE_TESTS),y)
-CONFIGURE_ARGS += --enable-verbose-tests
-endif
-
-ifeq ($(filter $(CONFIG_RUST_CCACHE) $(CCACHE),y),)
-CONFIGURE_ARGS += --enable-ccache
-endif
-
-ifeq ($(CONFIG_RUST_CCACHE),y)
-CONFIGURE_ARGS += --enable-ccache
-endif
-
-ifeq ($(CONFIG_RUST_LLVM_STATIC),y)
-CONFIGURE_ARGS += --enable-llvm-static-stdcpp
-endif
-
-ifeq ($(CONFIG_RUST_LLVM_SHARED),y)
-CONFIGURE_ARGS += --enable-llvm-link-shared
-endif
-
-ifeq ($(CONFIG_RUST_CODEGEN_TESTS),y)
-CONFIGURE_ARGS += --enable-codegen-tests
-endif
-
-ifeq ($(CONFIG_RUST_OPTION_CHECKING),y)
-CONFIGURE_ARGS += --enable-option-checking
-endif
-
-ifeq ($(CONFIG_RUST_ENABLE_NINJA),y)
-CONFIGURE_ARGS += --enable-ninja
-endif
-
-ifeq ($(CONFIG_RUST_LOCKED_DEPS),y)
-CONFIGURE_ARGS += --enable-locked-deps
-endif
-
-ifeq ($(CONFIG_RUST_VENDOR),y)
-CONFIGURE_ARGS += --enable-vendor
-endif
-
-ifeq ($(CONFIG_RUST_SANITIZERS),y)
-CONFIGURE_ARGS += --enable-sanitizers
-endif
-
-ifeq ($(CONFIG_RUST_DIST_SRC),y)
-CONFIGURE_ARGS += --enable-dist-src
-endif
-
-ifeq ($(CONFIG_RUST_CARGO_NATIVE_STATIC),y)
-CONFIGURE_ARGS += --enable-cargo-native-static
-endif
-
-ifeq ($(CONFIG_RUST_PROFILER),y)
-CONFIGURE_ARGS += --enable-profiler
-endif
-
-ifeq ($(CONFIG_RUST_FULL_TOOLS),y)
-CONFIGURE_ARGS += --enable-full-tools
-endif
-
-ifeq ($(CONFIG_RUST_MISSING_TOOLS),y)
-CONFIGURE_ARGS += --enable-missing-tools
-endif
-
-ifeq ($(CONFIG_RUST_USE_LIBCXX),y)
-CONFIGURE_ARGS += --enable-use-libcxx
-endif
-
-ifeq ($(CONFIG_RUST_CONTROL_FLOW_GUARD),y)
-CONFIGURE_ARGS += --enable-control-flow-guard
-endif
-
-ifeq ($(CONFIG_RUST_OPTIMIZE_LLVM),y)
-CONFIGURE_ARGS += --enable-optimize-llvm
-endif
-
-ifeq ($(CONFIG_RUST_LLVM_ASSERTIONS),y)
-CONFIGURE_ARGS += --enable-llvm-assertions
-endif
-
-ifeq ($(CONFIG_RUST_DEBUG_ASSERTIONS),y)
-CONFIGURE_ARGS += --enable-debug-assertions
-endif
-
-ifeq ($(CONFIG_RUST_LLVM_RELEASE_DEBUGINFO),y)
-CONFIGURE_ARGS += --enable-llvm-release-debuginfo
-endif
-
-ifeq ($(CONFIG_RUST_MANAGE_SUBMODULES),y)
-CONFIGURE_ARGS += --enable-manage-submodules
-endif
-
-ifeq ($(CONFIG_RUST_FULL_BOOTSTRAP),y)
-CONFIGURE_ARGS += --enable-full-bootstrap
-endif