knot: upgrade to 2.5.3
authorDaniel Salzman <daniel.salzman@nic.cz>
Tue, 1 Aug 2017 09:45:39 +0000 (11:45 +0200)
committerDaniel Salzman <daniel.salzman@nic.cz>
Wed, 20 Sep 2017 14:01:10 +0000 (16:01 +0200)
Update the default config file to reflect the server changes.
Remove no longer applicable patch.

Signed-off-by: Daniel Salzman <daniel.salzman@nic.cz>
net/knot/Makefile
net/knot/patches/02_knot.conf.patch
net/knot/patches/03_contrib_files.patch [deleted file]

index 9a1be4399eebf36e425b4106026c6ac50cd9c1a3..2e149e1c3ef85699f13698a142e7bb5d3065a8f7 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=knot
-PKG_VERSION:=2.3.3
+PKG_VERSION:=2.5.3
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://secure.nic.cz/files/knot-dns/
-PKG_HASH:=a929bce3b957a81776b1db7b43b0e4473339bf16be8dbba5abb4b0593bf43c94
+PKG_HASH:=d78ae231a68ace264f5738c8e57481923bcad7413f3f440c06fa6cc0aded9d8e
 
 PKG_MAINTAINER:=Daniel Salzman <daniel.salzman@nic.cz>
 PKG_LICENSE:=GPL-3.0 LGPL-2.0 0BSD MIT OLDAP-2.8
@@ -44,7 +44,7 @@ endef
 define Package/knot-libs
        $(call Package/knot-lib/Default)
        TITLE+= common DNS and DNSSEC libraries
-       DEPENDS+=+libgnutls +jansson
+       DEPENDS+=+libgnutls
 endef
 
 define Package/knot-libzscanner
@@ -151,8 +151,7 @@ CONFIGURE_ARGS +=                   \
        --with-rundir=/var/run/knot     \
        --with-storage=/var/lib/knot    \
        --with-configdir=/etc/knot      \
-       --with-timer-mapsize=50         \
-       --with-conf-mapsize=50
+       --with-conf-mapsize=20
 
 TARGET_CFLAGS += -DPSELECT_COMPAT -DNDEBUG
 
index 215b09fbed153bb0930845a87f29395e2ac2858d..54ad80b75f04205d7ba96fde66fef98e85b08020 100644 (file)
@@ -1,5 +1,5 @@
 diff --git a/samples/knot.sample.conf.in b/samples/knot.sample.conf.in
-index e07c8a7..ecc13ad 100644
+index e07c8a7..8e057b0 100644
 --- a/samples/knot.sample.conf.in
 +++ b/samples/knot.sample.conf.in
 @@ -9,7 +9,7 @@ server:
@@ -11,3 +11,14 @@ index e07c8a7..ecc13ad 100644
  
  log:
      # Log info and more serious events to syslog.
+@@ -33,7 +33,9 @@ acl:
+ #    action: notify
+ template:
+-#  - id: default
++   - id: default
++     max-journal-db-size: 20M
++     max-timer-db-size: 5M
+ #    storage: "@storage_dir@"
+ zone:
diff --git a/net/knot/patches/03_contrib_files.patch b/net/knot/patches/03_contrib_files.patch
deleted file mode 100644 (file)
index 02f5198..0000000
+++ /dev/null
@@ -1,15 +0,0 @@
-diff --git a/src/contrib/files.c b/src/contrib/files.c
-index 8aee482..12f36ca 100644
---- a/src/contrib/files.c
-+++ b/src/contrib/files.c
-@@ -24,6 +24,10 @@
- #include <sys/stat.h>
- #include <unistd.h>
-+#ifndef O_NOFOLLOW
-+#define O_NOFOLLOW 0
-+#endif
-+
- static bool special_name(const char *name)
- {
-       return strcmp(name, ".") == 0 || strcmp(name, "..") == 0;