flashrom: update to v0.9.9.1
authorÁlvaro Fernández Rojas <noltari@gmail.com>
Sun, 31 Dec 2017 17:50:19 +0000 (18:50 +0100)
committerÁlvaro Fernández Rojas <noltari@gmail.com>
Sun, 31 Dec 2017 17:50:19 +0000 (18:50 +0100)
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
utils/flashrom/Makefile
utils/flashrom/patches/0001-fix_internal_bitbang.patch
utils/flashrom/patches/0002-fix-io-h-include.patch

index cbb0ff3c1ed219d74ddd79502b7294d2b92c3b0e..df0561a2ab71ed0ea8a9998bb62485cfb4e7dcf8 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2010-2016 OpenWrt.org
+# Copyright (C) 2010-2017 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=flashrom
-PKG_VERSION:=0.9.9
-PKG_RELEASE:=2
+PKG_VERSION:=0.9.9.1
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://download.flashrom.org/releases
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_HASH:=cb3156b0f63eb192024b76c0814135930297aac41f80761a5d293de769783c45
+PKG_HASH:=0e145a5b9b18c98752acf0f8329a9a260ddf030abf687416daab9f05a0f508d0
 PKG_MAINTAINER:=Álvaro Fernández Rojas <noltari@gmail.com>
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_SOURCE_SUBDIR)
index 376d6b285d7fcd0d0b5ea4b44affe5b2faf342b1..581e0704a23a73f0b50361e2aef64ea60d184764 100644 (file)
@@ -1,6 +1,6 @@
 --- a/programmer.h
 +++ b/programmer.h
-@@ -557,7 +557,7 @@ enum spi_controller {
+@@ -584,7 +584,7 @@ enum spi_controller {
  #if CONFIG_DEDIPROG == 1
        SPI_CONTROLLER_DEDIPROG,
  #endif
index 50aa2a8fae3c69a4544f00afbb8ec1390a8d4e6d..63109e1f11fd17f9feaa38e07d59c62042ab91ec 100644 (file)
@@ -1,12 +1,10 @@
-diff -uprN a/linux_spi.c b/linux_spi.c
---- a/flash.h     2015-02-08 16:57:52.000000000 -0500
-+++ b/flash.h     2016-01-08 20:09:51.599387507 -0500
+--- a/flash.h
++++ b/flash.h
 @@ -30,6 +30,7 @@
  #include <stdio.h>
  #include <stdint.h>
  #include <stddef.h>
 +#include <sys/io.h>
+ #include <stdarg.h>
  #include <stdbool.h>
  #if IS_WINDOWS
- #include <windows.h>
-