openvswitch: python: remove openvswitch as a dependency
authorYousong Zhou <yszhou4tech@gmail.com>
Tue, 13 Feb 2018 07:51:01 +0000 (15:51 +0800)
committerYousong Zhou <yszhou4tech@gmail.com>
Mon, 5 Mar 2018 16:29:53 +0000 (00:29 +0800)
The python library is a standalone unit.  Remove dependency on
PACKAGE_openvswitch to allow users to use it with maybe remote
openvswitch services.

Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
net/openvswitch/Makefile

index 8887a561909ec43e08b47860c1d8b3b40a2e474d..65f1237bc4d97baecd0f559e5cd4bd72e7810b42 100644 (file)
@@ -102,7 +102,7 @@ endef
 define Package/openvswitch-python
   $(call Package/openvswitch/Default)
   TITLE:=Open vSwitch Python Support
-  DEPENDS:=+openvswitch +PACKAGE_openvswitch-python:python +PACKAGE_openvswitch-python:python-six
+  DEPENDS:=+PACKAGE_openvswitch-python:python +PACKAGE_openvswitch-python:python-six
 endef
 
 define Package/openvswitch-python/description