Python3: Fix host build on OpenSUSE
authorJan Kardell <jan.kardell@telliq.com>
Mon, 1 Oct 2018 17:13:44 +0000 (19:13 +0200)
committerJeffery To <jeffery.to@gmail.com>
Wed, 20 May 2020 09:28:02 +0000 (17:28 +0800)
The linker option -rpath is required to find libs in staging_dir. Now it
is included when building host modules. Without it the import test of
the _ctypes and _uuid modules would fail. The _ctypes module uses
libffi.so.6 from staging, but OpenSUSE LEAP 15 has libffi.so.7.
It will also fail on LEAP 42.x, Fedora28 and 29 and future or old
versions of Ubuntu.

Fix needed in master and 18.06 branches.

Signed-off-by: Jan Kardell <jan.kardell@telliq.com>
(cherry picked from commit 6ade5a1e3adb189d062b707e2b8f731c9faab844)

lang/python/python3/Makefile

index 32b564cb4d7c4f88477690aefd0b803e125d1552..5180ee928e98d3936c8bdc5ac3ddca850e630193 100644 (file)
@@ -264,7 +264,7 @@ define Py3Package/python3/filespec
 endef
 
 HOST_LDFLAGS += \
-       $$$$(pkg-config --static --libs libcrypto libssl)
+       $$$$(pkg-config --static --libs libcrypto libssl) -Wl$(comma)-rpath=$(STAGING_DIR_HOSTPKG)/lib
 
 ifeq ($(HOST_OS),Linux)
 HOST_LDFLAGS += \