haproxy: Update HAProxy to v2.4.4
authorChristian Lachner <gladiac@gmail.com>
Wed, 8 Sep 2021 06:21:55 +0000 (08:21 +0200)
committerRosen Penev <rosenp@gmail.com>
Wed, 8 Sep 2021 14:32:53 +0000 (07:32 -0700)
- This update fixes CVE-2021-40346; see: https://jfrog.com/blog/critical-vulnerability-in-haproxy-cve-2021-40346-integer-overflow-enables-http-smuggling/
- Update haproxy download URL and hash
- Make use of $(AUTORELEASE) for PKG_RELEASE

Signed-off-by: Christian Lachner <gladiac@gmail.com>
net/haproxy/Makefile
net/haproxy/get-latest-patches.sh

index ef73fc61a11c36b7e273c67712d8df3490c0c574..d9025b8b20e5b1eda02fe53d76246b3b251203ef 100644 (file)
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=haproxy
-PKG_VERSION:=2.4.3
-PKG_RELEASE:=1
+PKG_VERSION:=2.4.4
+PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://www.haproxy.org/download/2.4/src
-PKG_HASH:=ce479380be5464faa881dcd829618931b60130ffeb01c88bc2bf95e230046405
+PKG_HASH:=116b7329cebee5dab8ba47ad70feeabd0c91680d9ef68c28e41c34869920d1fe
 
 PKG_MAINTAINER:=Thomas Heil <heil@terminal-consulting.de>, \
                Christian Lachner <gladiac@gmail.com>
index 8c8d464c03c4c23ddec33572be9b4a7c5f9122c3..f664cfdd6a66baa4ab6013f8e8bda5eeb6dab312 100755 (executable)
@@ -1,7 +1,7 @@
 #!/bin/sh
 
 CLONEURL=https://git.haproxy.org/git/haproxy-2.4.git
-BASE_TAG=v2.4.3
+BASE_TAG=v2.4.4
 TMP_REPODIR=tmprepo
 PATCHESDIR=patches