zstd: update to 1.5.0
authorRosen Penev <rosenp@gmail.com>
Sun, 24 Oct 2021 18:34:25 +0000 (11:34 -0700)
committerRosen Penev <rosenp@gmail.com>
Mon, 25 Oct 2021 00:52:20 +0000 (17:52 -0700)
Remove uClibc hack. uClibc is not in the tree anymore.

Update configure options. Change legacy_level to 7. This gets rid of
backwards compatibility with version 0.1 and bumps it to 0.7.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
utils/zstd/Makefile
utils/zstd/patches/001-fix-meson.patch [deleted file]

index 62e82d6a2a44248e4990518576c5d966a16ec871..b2345e36e5f4ab24100c82740dfd130646de9675 100644 (file)
@@ -1,12 +1,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=zstd
-PKG_VERSION:=1.4.9
-PKG_RELEASE:=1
+PKG_VERSION:=1.5.0
+PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.zst
 PKG_SOURCE_URL:=https://github.com/facebook/zstd/releases/download/v$(PKG_VERSION)
-PKG_HASH:=61dce0e9a5036d7fb9b5709ee6567c2c8a1b4ba48a8e43afe9ae355cc37bb494
+PKG_HASH:=9aa8dfc1ca17f358b28988ca1f6e00ffe1c6f3198853f8d2022799e6f0669180
 
 PKG_MAINTAINER:=
 PKG_LICENSE:=GPL-2.0-or-later
@@ -63,16 +63,15 @@ ifeq ($(CONFIG_ZSTD_OPTIMIZE_O3),y)
 TARGET_CFLAGS:= $(filter-out -O%,$(TARGET_CFLAGS)) -O3
 endif
 
-TARGET_CFLAGS += $(if $(CONFIG_USE_UCLIBC),-D_BSD_SOURCE)
-
 MESON_ARGS += \
-       -Dlegacy_level=1 \
+       -Dlegacy_level=7 \
        -Ddebug_level=0 \
        -Dbacktrace=false \
        -Dstatic_runtime=false \
        -Dbin_programs=true \
        -Dbin_tests=false \
-       -Dbin_control=false \
+       -Dbin_contrib=false \
+       -Dmulti_thread=enabled \
        -Dzlib=disabled \
        -Dlzma=disabled \
        -Dlz4=disabled \
diff --git a/utils/zstd/patches/001-fix-meson.patch b/utils/zstd/patches/001-fix-meson.patch
deleted file mode 100644 (file)
index f9a69d0..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
-Fixes build issue https://github.com/facebook/zstd/issues/2519
---- a/build/meson/lib/meson.build
-+++ b/build/meson/lib/meson.build
-@@ -22,6 +22,7 @@ libzstd_sources = [join_paths(zstd_rootd
-   join_paths(zstd_rootdir, 'lib/common/threading.c'),
-   join_paths(zstd_rootdir, 'lib/common/pool.c'),
-   join_paths(zstd_rootdir, 'lib/common/zstd_common.c'),
-+  join_paths(zstd_rootdir, 'lib/common/zstd_trace.c'),
-   join_paths(zstd_rootdir, 'lib/common/error_private.c'),
-   join_paths(zstd_rootdir, 'lib/common/xxhash.c'),
-   join_paths(zstd_rootdir, 'lib/compress/hist.c'),