php7: disable valgrind support
authorMichael Heimpold <mhei@heimpold.de>
Fri, 22 Dec 2017 21:00:20 +0000 (22:00 +0100)
committerMichael Heimpold <mhei@heimpold.de>
Thu, 28 Dec 2017 21:00:07 +0000 (22:00 +0100)
The check to enable/disable this new feature of PHP 7.2 works
incorrectly when cross-compiling because it detects the host headers
only and there is no way to pass in a dedicated directory.

The wish to change this was reported upstream at:
https://bugs.php.net/bug.php?id=75722

For the meantime, use a self-cooked patch.

Signed-off-by: Michael Heimpold <mhei@heimpold.de>
lang/php7/Makefile
lang/php7/patches/1008-acinclude-valgrind.patch [new file with mode: 0644]

index bc930f094c3f050fdc93af0080118d00c21ddfd8..2f4e56829412c3091b3efd99bf14f4ad8f01614e 100644 (file)
@@ -469,6 +469,7 @@ CONFIGURE_VARS+= \
        iconv_impl_name="gnu_libiconv" \
        ac_cv_php_xml2_config_path="$(STAGING_DIR)/host/bin/xml2-config" \
        ac_cv_u8t_decompose=yes \
+       ac_cv_enable_valgrind_check=no \
 
 define Package/php7/conffiles
 /etc/php.ini
diff --git a/lang/php7/patches/1008-acinclude-valgrind.patch b/lang/php7/patches/1008-acinclude-valgrind.patch
new file mode 100644 (file)
index 0000000..a3eae9c
--- /dev/null
@@ -0,0 +1,42 @@
+--- a/acinclude.m4     2017-11-28 10:22:53.000000000 +0100
++++ b/acinclude.m4     2017-12-22 16:28:09.361331754 +0100
+@@ -3227,20 +3227,26 @@
+ dnl PHP_CHECK_VALGRIND
+ AC_DEFUN([PHP_CHECK_VALGRIND], [
+-  AC_MSG_CHECKING([for valgrind])
++  AC_CACHE_CHECK(whether to enable the check for valgrind support,ac_cv_enable_valgrind_check,[
++    ac_cv_enable_valgrind_check=yes
++  ])
+-  SEARCH_PATH="/usr/local /usr"
+-  SEARCH_FOR="/include/valgrind/valgrind.h"
+-  for i in $SEARCH_PATH ; do
+-    if test -r $i/$SEARCH_FOR; then
+-      VALGRIND_DIR=$i
+-    fi
+-  done
++  if test "$ac_cv_enable_valgrind_check" = "yes"; then
++    AC_MSG_CHECKING([for valgrind])
++
++    SEARCH_PATH="/usr/local /usr"
++    SEARCH_FOR="/include/valgrind/valgrind.h"
++    for i in $SEARCH_PATH ; do
++      if test -r $i/$SEARCH_FOR; then
++        VALGRIND_DIR=$i
++      fi
++    done
+-  if test -z "$VALGRIND_DIR"; then
+-    AC_MSG_RESULT([not found])
+-  else
+-    AC_MSG_RESULT(found in $VALGRIND_DIR)
+-    AC_DEFINE(HAVE_VALGRIND, 1, [ ])
++    if test -z "$VALGRIND_DIR"; then
++      AC_MSG_RESULT([not found])
++    else
++      AC_MSG_RESULT(found in $VALGRIND_DIR)
++      AC_DEFINE(HAVE_VALGRIND, 1, [ ])
++    fi
+   fi
+ ])