icu: fix ccache issue
authorHirokazu MORIKAWA <morikw2@gmail.com>
Fri, 10 Mar 2023 04:01:22 +0000 (13:01 +0900)
committerTianling Shen <cnsztl@gmail.com>
Sat, 11 Mar 2023 02:23:29 +0000 (10:23 +0800)
build error with ccache:
https://github.com/openwrt/packages/issues/20618

Signed-off-by: Hirokazu MORIKAWA <morikw2@gmail.com>
libs/icu/Makefile

index 3534d5d806c45bcd8c482d9f38660748ae2a3144..b34c226f4e0a72763023e597fa405b3dd89ace76 100644 (file)
@@ -11,7 +11,7 @@ PKG_NAME:=icu4c
 MAJOR_VERSION:=72
 MINOR_VERSION:=1
 PKG_VERSION:=$(MAJOR_VERSION).$(MINOR_VERSION)
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(MAJOR_VERSION)_$(MINOR_VERSION)-src.tgz
 PKG_SOURCE_URL:=https://github.com/unicode-org/icu/releases/download/release-$(MAJOR_VERSION)-$(MINOR_VERSION)
@@ -79,8 +79,8 @@ endef
 CONFIGURE_CMD:= ./runConfigureICU
 CONFIGURE_ARGS:= \
        Linux/gcc \
-       CC="$(TARGET_CC)" \
-       CXX="$(TARGET_CXX)" \
+       CC="$(TARGET_CC_NOCACHE)" \
+       CXX="$(TARGET_CXX_NOCACHE)" \
        --target=$(GNU_TARGET_NAME) \
        --host=$(GNU_TARGET_NAME) \
        --build=$(GNU_HOST_NAME) \