net/mosquitto: Bump to 1.4.1
authorKarl Palsson <karlp@remake.is>
Fri, 10 Apr 2015 14:36:52 +0000 (14:36 +0000)
committerKarl Palsson <karlp@remake.is>
Fri, 10 Apr 2015 14:36:52 +0000 (14:36 +0000)
Some useful fixes:
http://mosquitto.org/2015/04/version-1-4-1-released/

Drops a patch that has been rolled into upstream.

Signed-off-by: Karl Palsson <karlp@remake.is>
net/mosquitto/Makefile
net/mosquitto/patches/100-libwebsockets-fixes.patch [deleted file]

index f7b0a918c5a359c95f9bcab830c655c33a0170d2..970a2356d85ce8fcd9e291f3d10ddf02f342dadf 100644 (file)
@@ -9,14 +9,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mosquitto
-PKG_VERSION:=1.4
-PKG_RELEASE:=2
+PKG_VERSION:=1.4.1
+PKG_RELEASE:=1
 PKG_LICENSE:=BSD-3-Clause
 PKG_LICENSE_FILES:=LICENSE.txt
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://mosquitto.org/files/source/
-PKG_MD5SUM:=cd879f5964311501ba8e2275add71484
+PKG_MD5SUM:=46008028563eb750c6aa93281ab2e181
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
diff --git a/net/mosquitto/patches/100-libwebsockets-fixes.patch b/net/mosquitto/patches/100-libwebsockets-fixes.patch
deleted file mode 100644 (file)
index 4d107b1..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/src/websockets.c b/src/websockets.c
-index 95f8a81..cf2b5e7 100644
---- a/src/websockets.c
-+++ b/src/websockets.c
-@@ -72,7 +72,7 @@ struct libws_http_data {
-       FILE *fptr;
- };
--#ifndef HTTP_STATUS_NOT_FOUND
-+#ifndef LWS_FEATURE_SERVE_HTTP_FILE_HAS_OTHER_HEADERS_ARG
-       /* This is libwebsockets 1.2.x or earlier, we have to degrade our capabilities.
-        * Once lws 1.3 is widely available this should be removed. */
- #     define LWS_IS_OLD