net/mosquitto: support more acl plugin options
authorKarl Palsson <karlp@etactica.com>
Tue, 27 Nov 2018 16:46:12 +0000 (16:46 +0000)
committerKarl Palsson <karlp@etactica.com>
Wed, 28 Nov 2018 10:15:04 +0000 (10:15 +0000)
Adds support for acl_plugin, and acl_opt_* options.
acl_opt_* requires some care as it relies on the internal behaviour of
cfg_load setting environment variables in a certain form.  However,
given that _all_ of the cfg_load infrastructure relies on that, we can
be pretty sure that it won't change in a way that will hurt us.

Originally reported as: https://github.com/openwrt/packages/pull/7434

Signed-off-by: Karl Palsson <karlp@etactica.com>
net/mosquitto/Makefile
net/mosquitto/files/etc/init.d/mosquitto

index 37daddc41441403f0e03e6d7258aca837dfa774f..515be4737e2827456f73651c8eec2af4b29c83a6 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mosquitto
 PKG_VERSION:=1.5.4
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 PKG_LICENSE:=BSD-3-Clause
 PKG_LICENSE_FILES:=LICENSE.txt
 PKG_CPE_ID:=cpe:/a:eclipse:mosquitto
index 0fa7a3a8f8053c617fa5efa3d46db78a952acf84..e7c1110c1034e1956e7d9f8223d837df67e6eb0c 100755 (executable)
@@ -91,6 +91,7 @@ convert_mosq_general() {
        append_if "$1" sys_interval
        append_if "$1" upgrade_outgoing_qos
        append_if "$1" user
+       append_optional_bool "$1" per_listener_settings
 }
 
 convert_persistence() {
@@ -144,6 +145,10 @@ add_listener() {
     append_optional_bool "$1" use_identity_as_username
     append_optional_bool "$1" use_subject_as_username
     append_if "$1" psk_hint
+    append_if "$1" auth_plugin
+
+    # Careful, this relies on internal behaviour of the cfg_load functions!
+    set | grep "CONFIG_$1_auth_opt_" | sed "s/^.*_\(auth_opt_.*\)='\(.*\)'/\1 \2/" >> $TCONF
 }
 
 add_topic() {