lcdgrilo: add new package 1867/head
authorW. Michael Petullo <mike@flyn.org>
Mon, 19 Oct 2015 02:22:08 +0000 (22:22 -0400)
committerW. Michael Petullo <mike@flyn.org>
Mon, 19 Oct 2015 02:22:08 +0000 (22:22 -0400)
Signed-off-by: W. Michael Petullo <mike@flyn.org>
multimedia/lcdgrilo/Makefile [new file with mode: 0644]
multimedia/lcdgrilo/files/lcdgrilo.init [new file with mode: 0644]

diff --git a/multimedia/lcdgrilo/Makefile b/multimedia/lcdgrilo/Makefile
new file mode 100644 (file)
index 0000000..53888d1
--- /dev/null
@@ -0,0 +1,50 @@
+#
+# Copyright (C) 2009-2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=lcdgrilo
+PKG_VERSION:=0.0.7
+PKG_RELEASE:=1
+
+PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
+
+PKG_LICENSE:=GPL-2.0
+PKG_LICENSE_FILES:=COPYING
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://www.flyn.org/projects/lcdgrilo
+PKG_MD5SUM:=80a946bf144da5cc32bdf9f1aa2f91e6
+PKG_BUILD_DEPENDS:=+vala
+
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/nls.mk
+
+define Package/lcdgrilo
+  SECTION:=multimedia
+  CATEGORY:=Multimedia
+  DEPENDS:=+grilo +grilo-plugins +libgee +libgstreamer1
+  TITLE:=lcdgrilo
+  URL:=http://www.flyn.org/projects/lcdgrilo/
+endef
+
+define Package/lcdgrilo/decription
+       A simple Grilo-based audio player meant to run on a Raspberry Pi with a PiFace CAD
+endef
+
+define Package/lcdgrilo/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/bin/lcdgrilo \
+               $(1)/usr/bin/
+       $(INSTALL_BIN) ./files/lcdgrilo.init $(1)/etc/init.d/lcdgrilo
+endef
+
+$(eval $(call BuildPackage,lcdgrilo))
diff --git a/multimedia/lcdgrilo/files/lcdgrilo.init b/multimedia/lcdgrilo/files/lcdgrilo.init
new file mode 100644 (file)
index 0000000..5c4ff1b
--- /dev/null
@@ -0,0 +1,16 @@
+#!/bin/sh /etc/rc.common
+# Copyright (C) 2009-2012 OpenWrt.org
+
+START=60
+
+start() {
+       /usr/bin/lcdgrilo &
+       echo $! > /var/run/lcdgrilo.pid
+}
+
+stop() {
+       if [ ! -f /var/run/lcdgrilo.pid ]; then
+               return
+       fi
+       /bin/kill `cat /var/run/lcdgrilo.pid`
+}