runc: enable seccomp support by default
authorDaniel Golle <daniel@makrotopia.org>
Thu, 19 Nov 2020 13:35:13 +0000 (13:35 +0000)
committerDaniel Golle <dangowrt@users.noreply.github.com>
Sat, 21 Nov 2020 23:55:47 +0000 (23:55 +0000)
It's nice to have seccomp support which is enabled in OpenWrt on
supported platforms on targets which are not marked as SMALL_FLASH.
(and it's kinda obvious that you wouldn't want to install runc on a
SMALL_FLASH target to begin with)
So let's enable seccomp by default.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
utils/runc/Makefile

index 8bece6b0a64bec0cbaef1145c9f99fb7912729fa..4d1fe8ca11bcbf017c32d1897a3d648d99479a26 100644 (file)
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=runc
 PKG_VERSION:=1.0.0-rc10
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 PKG_LICENSE:=Apache-2.0
 PKG_LICENSE_FILES:=LICENSE
 
@@ -26,9 +26,9 @@ include ../../lang/golang/golang-package.mk
 define Package/runc/config
 config RUNC_SECCOMP
        depends on PACKAGE_runc
+       depends on KERNEL_SECCOMP
        bool "Enable support for seccomp in runc"
-       default DOCKER_SECCOMP
-       select KERNEL_SECCOMP
+       default y
        select PACKAGE_libseccomp
        help
          Build runc with support for seccomp filters.